View Single Post
Old 07-25-2008, 02:19 PM   #1 (permalink)
Thumbs Must Hurt
Join Date: Nov 2007
Location: atm: Kunming norm: Berlin
Model: 8700v
Carrier: ChinaMobile
Posts: 55
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default another gps-simulator-problem

Please Login to Remove!

I have a problem running my gps-application in the simulator.
"LocationProvider lp = LocationProvider.getInstance(cr);" allways returns NULL...
criteria = null doesn't change anything...

I have started the "gps-simulation" and added a I have to do anything else? like start gps in the (simulated)device?

and why does getInstance return null and doesn't throw a LocationException which it shoud if no provider was available....

thx in advance

EDIT: ok, sorry I just noticed that getInstance() does return NULL "If no concrete LocationProvider could be created that typically can match the defined criteria but there are other location providers not meeting the criteria that could be returned for a more relaxed criteria"...
still I don't understand why the default LP is not found in the simulator...?
and if there are other LPs available, how do I get those?

EDIT2: ok,ok problem solved...that was stupid...the pearl doesn't have a gps-module? I just had to switch on the gps bluetooth in range option in the simulator............

Last edited by jenselense : 07-26-2008 at 04:02 AM. Reason: solved...
Offline   Reply With Quote