View Single Post
Old 09-05-2008, 09:03 AM   #1 (permalink)
Knows Where the Search Button Is
Join Date: Dec 2007
Model: 8320
Carrier: T-Mobile
Posts: 25
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Trouble with email again...

Please Login to Remove!

I'll try to be as detailed as possible about my situation.

I posted about this situation once before. I've been having trouble with the BB T-Mo has been giving me. At 1st I had one that would restart itself over and over again, which they sent me a replacement. The 2nd one worked for a week, and stopped getting any emails. I called T-Mo told them the situation, they did a few trouble shoots nothing worked, and they said they would send me another phone. During the time waiting for the phone, I came here seeking for more information. A lot of the members here told me that my best bet is to update the OS from 4.2 to 4.5. As soon as I got the replacement phone, the first thing I did was update the OS. The update is great, everything worked fine for about 2 weeks, till last night I got my last email around 11:30pm. Checking my phone again at 5am, I had no new mails, but as I logged on my gmail account online, I had 5 new mails.

Along with not getting any mails, I noticed that the hour glass would pop up every 5 seconds on my screen for at least 2 seconds, disappear, and reappear 5 seconds later. As if something was running in the background. Its not like I can hit Alt Ctrl Del and get the task manager screen and shut down what ever is taking up my battery life.

So I did the whole pull the battery, send service book, that didn't work. Now I tried, sending the hosting router, pulling the battery, and sending service book again. Nothing work, while doing this I did send test emails to myself, which I never received on my BB.

I feel like calling T-Mo and *****ing at them, but I have a good feeling they will tell me its a device issue and send me a replacement again. But I feel like this isn't a device issue at all, but something more to do at T-Mo's end. I might be wrong.

What are the best options I have to fix this issue?
Offline   Reply With Quote