View Single Post
Old 09-12-2008, 12:52 PM   #10 (permalink)
KPO'M
New Member
 
Join Date: Sep 2008
Model: 8700c
PIN: N/A
Carrier: AT&T & T-Mobile
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by KPO'M View Post
I upgraded an 8700c that I had previously unlocked. The upgrade installed fine, but now it seems that it has re-locked to AT&T (note I did remove the vendor.xml file). I don't have my unlock code handy, but I'll try it if I can find it. Has anyone else experienced this? When I insert my T-Mobile SIM, I get an "Initialization Failed" message. I've tried taking the battery and SIM out and restarting.

Any ideas?

Note I had my T-Mobile SIM in the BB for the entire process.
My solution so far has been to downgrade to 4.2. Under 4.1, my T-Mobile SIM worked just fine. Under 4.2, it works fine, but if I power it down, the only way to avoid an "initialization failed" message on restart is to remove and reinsert the battery (an AT&T SIM handles this OK). Under 4.5, I get the initialization failed error message all the time with the T-Mobile SIM, even if I remove and reinsert the battery.
Offline   Reply With Quote