View Single Post
Old 09-12-2008, 07:44 PM   #63 (permalink)
alreadyused
New Member
 
Join Date: Sep 2008
Model: 8100
OS: 4.2.1.107
PIN: N/A
Carrier: t-mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default uggh - 8100 & T-Mobile with Ubuntu 8.0.4

I'm close, I think.
I'm pretty new to Linux, so I'm struggling with that a bit.
I have the Blackberry plan through T-Mobile; I've been connecting via bluetooth tether and Win XP for about a year, so I have that working.

I'm really looking for:
1. What's my problem? (Not life in general, just this issue )
2. Can someone explain or point me to understanding this? Yes I want to fix it, but I also want to understand it.
3. Shouldn't noauth tell my computer NOT to send user / password?

So that said, I'm following SDNick484's directions (#41), bluetooth tethering
  • setup the rfcomm.conf (had to change to channel 1 based on spdtool)
  • do the bberry script
  • do the bberry_chat script (w/ tmo OK 'AT+CGDCONT=1,"IP","wap.voicestream.com","",0,0')

I'm thinking I may have an issue with the PAP, but not sure???

I tried this second but it's shorter, so in the bberry script, if I try:
Code:
noauth
user 'guest' # or "", and verified plain text
password ''
It gets most of the way through the connection, then I see (not verbatim)
Code:
rcvd PAP something user=""
sent PAP something user="guest"
...
something about a timeout
If I drop guest out of user, so I have user '' or user "", then it seems my computer is sending the computer name as the user name. My results from that are at the bottom, because that's a long post.

So, I have seen mentions that although T-Mobile doesn't need the PAP, but my computer might require it? I tried a lot of things last night, but didn't get a chance to test that.

Thanks for bearing with me.

No user name results:
Code:
Serial connection established.
using channel 17
Using interface ppp0
Connect: ppp0 <--> /dev/rfcomm1
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x8a06e674> <pcomp> <accomp>]
rcvd [LCP ConfReq id=0x0 <asyncmap 0x0> <auth chap MD5>]
sent [LCP ConfNak id=0x0 <auth pap>]
rcvd [LCP ConfRej id=0x1 <magic 0x8a06e674> <pcomp> <accomp>]
sent [LCP ConfReq id=0x2 <asyncmap 0x0>]
rcvd [LCP ConfReq id=0x1 <asyncmap 0x0> <auth pap>]
sent [LCP ConfAck id=0x1 <asyncmap 0x0> <auth pap>]
rcvd [LCP ConfAck id=0x2 <asyncmap 0x0>]
sent [PAP AuthReq id=0x1 user="dims-8200" password=<hidden>]
... (0x2 to 2x9 trunc'd)
sent [PAP AuthReq id=0xa user="dims-8200" password=<hidden>]
No response to PAP authenticate-requests
sent [LCP TermReq id=0x3 "Failed to authenticate ourselves to peer"]
sent [LCP TermReq id=0x4 "Failed to authenticate ourselves to peer"]
Connection terminated.
*EDIT* My phone is an 8100, v4.2.1.107 on Platform 2.3.0.83, not unlocked

Last edited by alreadyused : 09-15-2008 at 01:57 PM.
Offline   Reply With Quote