View Single Post
Old 11-12-2008, 02:32 PM   #1 (permalink)
NeptuneIT
Thumbs Must Hurt
 
NeptuneIT's Avatar
 
Join Date: Nov 2005
Location: AL
Model: 9000
Carrier: AT&T
Posts: 123
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default New media card not recognized

Please Login to Remove!

I just got a media card from Newegg (Newegg.com - Kingston 8GB Micro SDHC Mobility Multi Kit Model MBLY/8GB - Flash Memory) and it is not being recognized by my Bold or my computer. When I enter the card in my Bold it says "Media Card inserted" but when I go to Options -> Memory it shows "Media card cannot be read. Verify that the memory card is formatted." I can hit the bb button and select Format and choose media card and it looks like it is doing something and then shows an error "Media Card Format Failed".

I have an SD card reader on my computer (1 yr old running Vista Business). I have tried the adapter that came with the card and a spare adapter I have and the USB adapter that came with the card and none of them work. When I insert the card the adapter shows up as Removable Disk (Drive Letter: ) but it says no media inserted. I've tried going to Disk Management and rescanning for disks and everything without any luck. I've also tried on an XP machine with the same results.

I've also tried a 2 GB microSD card that I have and it works in the USB adapter and the SD adapter and in my Bold.

It seems to me that I may have gotten a defective card. Does anyone else have an idea to try before I send it back to newegg?

Last edited by NeptuneIT : 11-12-2008 at 02:43 PM.
Offline   Reply With Quote