View Single Post
Old 07-26-2009, 11:52 AM   #40 (permalink)
Chana
New Member
 
Join Date: Jul 2009
Model: 8600
PIN: N/A
Carrier: fido
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

[quote=Raptor464;1330107]This is the correct procedure to follow if your trackball click function is lost. I have performed it quite a few times on multiple berry's and have had success every time. What happens sometimes is moisture can get into the contact's housing which causes some corrosion. By prying up the tape slightly exposing the contact, you can clean the corrosion with a small blade. What I have had the most trouble with is with the resetting of the contact into the housing. It can take multiple tries to get the contact to sit it the perfect position so that the edges make contact with the side contacts and the center of the button is able to touch the center contact upon depression. Be very careful when cleaning the contact itself with alcohol because if you do not allow enough time for the alcohol to dry, your contact will again become corroded and not function correctly. I would love to post a step by step instruction on this procedure but I do not have a high resolution camera to take pictures.



I tried the CrackBerryHead procedure that you posted and followed all the instructions. When I strated up my phone again and clicked on the trackball the click was more of a click, it pushed deeper but it still didn't register as a click on the phone. So although it would seem that it works better by the way pushing the trackball feels (and sounds) I am still stuck with the same problem...
Any ideas?
Offline   Reply With Quote