View Single Post
Old 08-21-2009, 09:36 PM   #1 (permalink)
2009.MOBILE
New Member
 
Join Date: Aug 2009
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Eclipse plugin, preverify step: I/O Error: Cannot run program "jar"

Please Login to Remove!

Hi all,

When I preverify the BlackBerry app I'm developing using the Eclipse plugin, I get the following error:
Code:
I/O Error: Cannot run program "jar": CreateProcess error=2, The system cannot find the file specified
This is the same error described in this thread:
developer-forum/137911-i-o-error-cannot-run-program-jar-eclipse-plugin.html

However, I don't know how to fix it using the instructions in that thread. All I see in the Installed Components tree item of the BlackBerry Preferences window is "Choose one of installed Components", nothing about Java Home. Also, how do I modify a PATH variable as described?

Also, I don't think my problem is related to the BlackBerry Preferences as a whole messing up, because I have many projects and only some of them are getting this error, while others are preverifying without error. This is the output when I press Build Active BlackBerry Configuration (with project names edited out):

Code:
Executing rapc for the project [Project1] at Fri Aug 21 18:48:43 PDT 2009.
C:\Program Files\Eclipse\plugins\net.rim.eide.componentpack4.5.0_4.5.0.16\components\bin\launcher.exe C:\Program Files\Eclipse\plugins\net.rim.eide.componentpack4.5.0_4.5.0.16\components\bin\rapc.exe  -quiet import="..\..\..\..\..\Program Files\Eclipse\plugins\net.rim.eide.componentpack4.5.0_4.5.0.16\components\lib\net_rim_api.jar" codename=..\[Project1]\[Project1] ..\[Project1]\[Project1].rapc warnkey=0x52435200 -sourceroot="C:\[...]\Workspace\[Project1]\src" @[Project1]_build.files
I/O Error: Cannot run program "jar": CreateProcess error=2, The system cannot find the file specified
rapc executed for the project [Project1]

Executing rapc for the project [Project2] at Fri Aug 21 18:41:01 PDT 2009.
C:\Program Files\Eclipse\plugins\net.rim.eide.componentpack4.5.0_4.5.0.16\components\bin\launcher.exe C:\Program Files\Eclipse\plugins\net.rim.eide.componentpack4.5.0_4.5.0.16\components\bin\rapc.exe  -quiet import=..\[Import1]\[Import1].jar;..\[Import2]\[Import2].jar;"..\..\..\..\..\Program Files\Eclipse\plugins\net.rim.eide.componentpack4.5.0_4.5.0.16\components\lib\net_rim_api.jar" codename=..\[Project2]\[Project2] ..\[Project2]\[Project2].rapc warnkey=0x52435200 -sourceroot="C:\[...]\Workspace\[Project2]\src" "C:\[...]\Workspace\[Project2]\bin"
rapc executed for the project [Project2]
The second project succeeded but the first one failed. Notice that the second project uses imports, while the first one doesn't. I found the automatically-generated line @[Project1]_build.files in the first highly suspicious, since there's no similar string in the second.

What's going on if the problem is just happening with some, but not all, of my projects?

Thanks!
Offline   Reply With Quote