View Single Post
Old 12-31-2009, 09:20 AM   #7 (permalink)
stevedubin
New Member
 
Join Date: Oct 2007
Location: South Florida
Model: 8320
OS: 4.5.0.81
PIN: N/A
Carrier: T-Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question Battery Drained - Meter Issue?

Quote:
Originally Posted by @meroo View Post
My 8320 had been running fine for months (OS 4.5.0.81), and now it has the low battery sign and says 'Battery drained. Shutting down handheld'.

The status menu it says 0% battery and when I unplug it turns off straight away. When it is in the charger but off, it flashes the green light.

I have tried pulling the battery several times. I've tried a different brand new battery which does not change outcome. I have left it plugged it into my wall, desk, car and usb charger and and it turns on but in the status menu it still says it is on 0% battery and when I unplug it turns off straight away.

I've tried everything I can think of including reset to factory, wiping OS with jl_cmder and re-intalling 4.5...can't be battery because device will remain on for hours with error 507 (no OS installed). Any advice would be greatly appreciated.

Good to see my search of the posts worked. It appears you have an identical problem as me. I'm on same OS, and have also troubleshot using all types of BB-specific chargers. And I too have just wiped the BB and reinstalled the OS (I initially had the 507 problem, and DM wouldn't recognize the BB to complete the reinstall. But I disconnected from the USB and hit the power button. It took a tremendously long boot-up time, but the phone came back on. Problem is, same issue with the battery showing no juice).

I've done almost exactly everything you have to try to fix this. In terms of testing the battery, I took the BB out of my Curve 8320 (where it read 0%) and put it into my wife's Curve 8320 (where it read 90%). Thought it was OS conflict, so I did the JL_Cmder and reinstall as mentioned above - yet still no change in battery meter status. (Pulled my 2GB media card before reinstalling the OS - yep, I read the threads!)

One thing for me that was a little different. After a series of pulling the battery and rebooting and still showing 0%, I left it attached to the computer USB cable so I could go have a good cry. But when I came back an hour or so later it showed 100% charged. I thought "great" and went to bed .... but when I woke up in the morning and looked at the BB it was down to 15% and hadn't been touched. No apps running besides the core (mail, phone, browser). No wi-fi either.

So - all cried out and still having to go to work and needing the phone, I put wife's battery into my BB. The meter showed 100%. Again, I thought "awesome, it's fixed". But by 3 hours later the meter showed 15% after virtually no use. I pulled the battery and installed into the other BB, where it showed in actuality it really had 90% charge still on it.

There were no programs I installed recently to impact the way I use this BB. There was no change in usage circumstances, no extra phone calls, etc. I never used a non-BB charger to impact voltage, etc.

My best guess is that the phone randomly got a glitch with the battery meter, then was working sporadically showing battery life, then turned to showing a fast drain, until now where the battery meter has proven completely unresponsive to anything and always shows 0% - regardless of the actual charge on the battery being inserted.

With 2 perfectly fine batteries working well when put into an identical model BB, I see no need to buy a new battery. Is it typical for hardware to shut itself down based on battery meter reading as opposed to actual battery power driving this function? Since re-installing my OS didn't work, should I look for a previous version of the OS instead? If so, would appreciate any direction on where to locate older versions.

Thanks for any help you can offer.
Offline   Reply With Quote