View Single Post
Old 05-31-2010, 06:28 PM   #1 (permalink)
Dirkies
New Member
 
Join Date: May 2010
Model: 9700
PIN: N/A
Carrier: LuxGSM
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Question since upgrade my 9700 keeps killing my DLink wifi router

Please Login to Remove!

Very weird issue...

Have a 9700 unlocked from T-Mobile and another unbranded 9700. Both work fine for everything, came orginally with (app) v321 firmware, upgraded to v423, all still fine, never any connection issues.

But since v545 right upto latest v680, the WLAN component was updated from version 2.7.0.60 (I believe, could have been .53 or .54) to 2.7.0.83, and the problems began with my DLink 2741B DSL b/g/n router.

Basically what happens is that once the BB is connected to the DLink (over WPA2), the DLink wireless radio dies within minutes, sometimes seconds. The router still works FINE over cable, but the signal of the radio disappears, and sometimes the AP will appear in wifi list but with strength zero.
Also, sometimes the wifi will come back OK (like connection dropped but comes back within 10s) but then dies again within a minute or so and does not recover anymore.

There is no need to do anything over wifi on the BB, just leave it connected, and you will see the wifi icon goes grey instead of white after a random period and bye bye wifi. Rescanning on the BB will not discovered the router anymore. All other devices on my wifi network also lose their connection aswell with the DLink wifi, it is almost like the BB blocks any device from accessing the hotspot, like a DOS attack would do.

Solution is to reboot the DLink, OR (and that is weird!) just go into the router menu over an ethernet cable, and run in maintenance menu a diagnosis test which shows all is ok, then the wifi comes back. (but will soon be killed again if the BB is active) Despite all possible logging enabled, nothing is logged the moment the wifi part dies. Nothing before, no packet errors, nada.

I tried all possible settings in advanced wifi on the router to see if tweaking strength, encryption etc makes a difference, but none help. WPA instead of WPA2 was tried to, no change, same behavior.

BOTH blackberry 9700s do the same, with older firmware, all fine, never an issue, but with post 423 firmware, the DLink will be dead within 5 minutes.

Anyone has an idea what else I can check for except downgrading my bold2?
Also note this DLink is rock steady otherwise, 4 PCs, Wii, XBox over wifi, (plus previously my BB 8820) plus some other wired devices connected to it, never let me down, but it seems this new WLAN version of the 9700 firmware sends some malformed packets to the router it cannot digest (or does a DOS alike attack) and kills the radio of the router within minutes.

Router has latest firmware, so can't change that.

Last edited by Dirkies : 05-31-2010 at 06:34 PM.
Offline   Reply With Quote