View Single Post
Old 06-21-2010, 03:27 AM   #26 (permalink)
carlos_2386
New Member
 
Join Date: Jun 2010
Model: 9700
PIN: N/A
Carrier: vodaphone
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by calycanto View Post
The post above with this advice worked for me. I'll repeat it again here. Seems like this happens when you let it run totally dead (as opposed to simply allowing the battery to run to the point the radio shuts off). Scary stuff!

Hi,

I had the same problem (big battery sign with light bolt), and this is how I got it to boot again.

1. While the BB was connected to the power wall, I removed the battery

2. I waited 30 seconds, you should see a red light during that time

3. I put the battery back, and then it rebooted back to the normal BB home screen. I noticed that the battery sign was red (AKA completely drain). By the way, if the BB does not come back after you put the battery back, and you wait a few seconds, just press the power button.

I'm going to wait a little bit and see if it charges completely.

I hope it helps.

M.
This also worked for me. give it a moment after replacing the battery, should work fine.
Offline   Reply With Quote