View Single Post
Old 10-17-2010, 01:16 PM   #1 (permalink)
New Member
Join Date: Jul 2010
Model: 9700
Carrier: Verizon
Posts: 11
Post Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Problem Using Socket Connection on AT&T network

Please Login to Remove!

I am trying to connect to a server over direct TCP. The connection string I am using ("socket://<IP-Address>:<port>;deviceside=true") works fine on verizon and T-mobile phones, but I am having problems on a telus bold 9700 with a&t SIM card (US). I am getting a CriticalIOException when I try to connect.

The details are:

Connection string: socket://<IP-Address>:<port>;deviceside=true;;T unnelAuthusername=null;TunnelAuthPassword=null


Critical tunnel failure

I have tried various prefixes of above connection string with and without username and password etc. Does anyone know what connection string should I use ? I have also tried apns 'proxy' and '' that have been suggested elsewhere.

The adv. settings->TCP/IP ... shows APN string "" and web browser seems to be working just fine.
Offline   Reply With Quote