View Single Post
Old 11-29-2010, 02:22 PM   #1 (permalink)
bluejae
Thumbs Must Hurt
 
Join Date: Mar 2005
Model: z10
Carrier: t-mobile
Posts: 183
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default bug while deleting several emails at once (all messages seem to disappear)

Please Login to Remove!

i've had this problem for a while... i've upgraded to different OS versions and none of them have remedied this problem...

here's how it goes...

when i receive emails, some are alerts so i just look at them and leave them... or at times, i'll delete them as i go... doing this tends to rack up many emails for months on my device... or every now and then i would want to delete them...

so for example... if i'm getting emails from an email address "abc"... i would do a search from my message window and find all emails that were sent by "abc"...

this would then give me every email from "abc"... if i know that i don't need any of these emails on my device anymore, the quickest way to delete all of them would be to go to the top of the list of emails that have been found and select 'Delete Prior'... once i do this, it will tell me it's 'Deleting' and soon it'll show a blank page with 'No Messages'...

now, this window i'm on is still the search window and the reason it's showing no messages is because i've deleted all the emails from "abc"... from here, if i press the 'back' button, it should take me to my main messages folder.. but instead it shows me nothing... it still says "no messages"...

so it almost seems like every email i had on my device has been deleted but that's not the case... i can still receive notifications that a new email has arrived but i can't view it... i learned today i can see some of the emails if i click on "view folders" and open up the inbox for one of my email accounts...

i also have my SMS and MMS in a different icon on my main screen... but all those are gone too... i can't see them... but i can receive a text message, hear the notification ring, but the notification icon isn't there, and nothing is visible in the sms messages folder until i do a battery pull.

the only solution i've found to bring them all back is a battery pull... once the device is rebooted... all my messages are once again viewable... and things are back to normal

but this problem seems to be isolated to only when i delete several items at once... i could have months and months of emails from "abc"... i could highlight about 2-3 weeks worth of emails and delete them, and everything will be fine...

i would hit 'b' to get to the bottom of the search query and then scroll up a few weeks and select 'Delete Prior' instead of highlighting, and it will delete every email from that point down from the list... and again, without a single problem... afterward i can push 'back' and view all my emails in my messages folder... it only happens when it's a large bulk of messages i delete at once, whether it's from one sender or several mixed messages from wherever... i don't know the exact number of messages that need to be deleted that triggers this bug/glitch...

so to avoid having to do a battery pull and wait 10 minutes or so... i just delete a handful of messages at a time... but if i happen to select too many, then i would have to do a battery pull...
Offline   Reply With Quote