View Single Post
Old 01-05-2011, 01:29 PM   #1 (permalink)
Efex
Knows Where the Search Button Is
 
Join Date: May 2007
Model: Pearl
PIN: N/A
Carrier: Movistar
Posts: 22
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Insert SIM card problem on my Curve 9300

Please Login to Remove!

Hi,

After a lof of search and reading I just couldn't find any solutions to this problem I'm having on my Curve 3G 9300

Last week I bought this phone at Ebay and is completely new. It's a T-Mobile Curve 9300 which has been unlocked, since I have checked with the MEPD and everything says disabled.

I'm trying to use the phone in south america with Movistar carrier but the phone just wont read any SIM card I've tried in it. (well, just one, read below)
After placing the battery and the phone restarts it shows Insert SIM card message and doesn't recognize the SIM card. Well, I've tryied like 5 or 6 different SIM's and the most strange thing is that it only works with one of them, which makes me think there's nothing wrong with the phone SIM reader or hardware :(
I keep trying SIM's and they don't work but this one I put it and every time the phone reads it with no problem.

I'm sure I'm placing the SIM's correctly btw, and also I went to the carrier to buy a new SIM card which didin't work either.

I've already reinstalled to the new OS6 but still nothing happened.

I don't know what else to do. At the carrier they told me it could be the frequency. They said they operate on 850mhz and US phones operate on 900Mhz and they could get the frequency down so it could work.
I'm not really sure that would be the problem but if I can't find any other solution I would have to take the phone to them to do that job and see if it works.

does anyone had this problem before? Anybody knows what it can be or how can I fix it?

The stangest thing of all is that when I first opened the box and put the SIM card it worked and it seemed to receive carrier data, but then I went to options and ran a phone check and then was when the problem began. Don't know if that was just coincidence or affected the phone at some point :(

please help me if u can!
Offline   Reply With Quote