View Single Post
Old 02-20-2011, 09:10 AM   #1 (permalink)
VAuser
New Member
 
Join Date: Feb 2011
Model: 8900
PIN: N/A
Carrier: ATT
Posts: 4
Post Thanks: 1
Thanked 0 Times in 0 Posts
Default Suspicous, old email delivered to BB, not to email acct; security features disabled

Please Login to Remove!

Help - I'm a regular user of my Blackberry Curve 8900 and never have used a community board before. I'm not a technical person, just someone who loves BB. I've been having a weird issue, that I think is security related.

Here's the problem: I continue receiving one particular email to my Blackberry 8900 that I had received in 2007 on my Yahoo account. It was legit in 2007 (and is still saved in my Yahoo acct), but not now. I received it a couple times before and deleted it, thinking it was some sort of virus or malware that got ahold of my friend's account. But it continues happening - I have three now - one from today (Feb 20, 2011), one from 2/18/11, and from 10/14/11. The person that sent it in 2007 told me she hasn't accidentally resent it, nor does it show up in her sent box as being sent to me again.

This morning, when I woke up, I turned my Blackberry on, and saw a blank email. Literally, an email with no sender's name on it and nothing showing up on the line. I assumed it was spam, so I turned on my laptop and looked at my Yahoo account to mark it. Didn't see it, so I looked at my Blackberry and the blank email turned into the name of my friend who sent the email in 2007 as well as the same title, "Coming back" (I'm assuming it's the same email, I just don't open them and look any more. Initially, I would turn my BB signal off, and open the email, then close and mark unread and turn the signal back on. That's how I know it's was the same email as 2007, but as I said, I don't even open them any more).

What has really alarmed me, is I just looked at my security on my BB (don't really know what I'm doing) and my firewall was on "disabled." I just enabled it.

Can anyone help me here? What the heck is going on?

Finally, should I just wipe the whole thing and restart the whole process from square one? That seems a bit extreme, which is why I'm turning to you all for help.

Thank you,
A perplexed, concerned user

Last edited by VAuser : 02-20-2011 at 09:44 AM. Reason: grammar and corrections
Offline   Reply With Quote