View Single Post
Old 05-11-2011, 06:29 PM   #1 (permalink)
ajsprot
New Member
 
Join Date: May 2011
Model: 8900
PIN: N/A
Carrier: Orange
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default No sound for calls

Please Login to Remove!

Hi,

A few days ago my phone died on me completely. This phone has been through the wars over the past year including being dropped in water (hence, voided warranty). I have managed to repair all up until now. The other day my phone gave me the red light of death and would not start up...no cause...it just did it when I woke up one day. Given I had nothing to lose, I opened it up. Put it back together and reflashed the OS to find it was working again. The only problem was the voice on calls was very quiet.

I opened it up again to realise the panel which holds the camera flash LED and the speaker was twisted slightly and had bent one of the pins on the speaker. I presumed this was a bad connection and why I was getting poor sound. I reseated everything and put it back together.

However, I now get NO sound at all during phone calls despite many reseatings. The loudspeaker and ringtones etc are fine. The camera and flash works fine. I can hear calls when I use speakerphone or a headset no problem. I even ordered a replacement speaker and replaced it with no luck. I'm extremely confused as everything is put back together the way it should be (otherwise the camera and louspeaker wouldn't work as they are) and the call audio/earpiece speaker is brand new!

Is it possible it could be an OS/software issue? I have reset it to factory settings with no success but I do still get an error message when I restart after a battery pull saying "Uncaught Exception Index 5 >= 5" ... the phone seems to function perfectly in every way other than sound during calls.

Put simply, any suggestions? Help would be greatly appreciated. I already know I shouldn't buy nice things
Offline   Reply With Quote