View Single Post
Old 01-23-2012, 12:52 PM   #22 (permalink)
NokiaFanToo
New Member
 
Join Date: Jan 2012
Location: USA
Model: 9900
PIN: N/A
Carrier: T-Mo USA
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Re: Leaked OS 7.1.0.205 for the 9900

The major reason I found to upgrade to this version *for my needs* is UMA/WiFi calling, so I'll restrict my comments to that. I found personally no other major issues except for GPS in this version compared to 7.0.0.540. I don't use "Mobile Hotspot" feature.

GPS was still problematic for me. GPS did not work after upgrade until I went into Device Analyzer GPS test.

UMA/WiFi calling problems (On T-Mobile service). I'll call it "WiFi Calling" for short since that's what Blackberry calls it, but they still refer to UMA in the menus of the phone:
- Similar functional issues as in 7.1.0.74 and 7.1.0.190 (I reported in .190 thread)
- WiFi calling range is limited to only about 10-13 meters from WiFi access point at full strength. I think this causes problems below.
- I find phone "hangs on" to the WiFi calling mode and doesn't drop back quickly enough to use 3G. Especially apparent at the limits of distance 10-13m. (WiFi calling "Preferred")
- Sometimes the phone has the UMA symbol on (meaning it "thinks" it's using WiFi calling), but: I'm unable to make outgoing calls, or the outgoing call connects but I cannot hear the far end (and far end can't hear me), or incoming calls don't ring. I find myself frequently needing to check that I can still dial calls. Phone continues to "hang onto" UMA mode and won't release it in this case until reboot or turn off WiFi calling.
- If I were to diagnose the problem it is that WiFi calling with this phone has a limited distance/signal strength range from the access point, and the UMA software logic is "hanging onto" the UMA mode too long even at distance limits...but calls can't come in/out. Similarly when returning to an area of strong WiFi, the phone doesn't switch back to WiFi quickly enough. Ultimately it seems as if the phone gets confused about whether WiFi calling is connected or not. This needs more debugging by RIM since I'm missing calls with UMA/WiFi enabled.

Edit:
For anyone looking to debug this issue, here are some particulars:
- Cisco WAP610N access point, and WNDR3700 AP/router. I've tried them in "N-only" mode and "G-only" mode with similar results with respect to above problems.
Also tried them with "WMM" disabled as well as enabled with similar results.
- Blackberry set to "WiFi preferred." When set to "Mobile Network" preferred, it never switches to WiFi calling
- My 3G coverage is poor in my area, so there could be some software logic problem with switching between the WiFi and network calling in that condition.
- WiFi diagnostics show no UMA-cell handover or rove-in failures, even when in the above mode where calls don't work.

Last edited by NokiaFanToo : 01-23-2012 at 01:16 PM.
Offline   Reply With Quote