View Single Post
Old 02-05-2012, 01:41 PM   #1 (permalink)
mikecoulthard
New Member
 
Join Date: Feb 2012
Model: 9810
PIN: N/A
Carrier: O2
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with my 9810 -Please Help!

Please Login to Remove!

Hi all

First of all I am new so please be gentle lol.

Got my 9810 today, obv running the BB 7 software. It was all working when I got it. Anyhow, I have a microsim in an adaptor and it got stuck in the 9810. So I went to the O2 shop and she snapped the adaptor in the phone and left plastic debrit inside that she managed to get out but looked rough with it.

Now the phone wont turn back on. Also the sim holder looks like it has lost some of the pins connectors under it, and the memory card clip is wonky.

What the phone does:

1. The red light flashes on for a few seconds then goes off.

2. When the red light goes off a faint egg timer comes on for a few second then goes off - this process happens over and over.

3. When i plug it into the computer via usb, the computer beeps when the red light is on, then beeps when it goes off for the egg timer - like it it going on and off.

4. When plugged in to the computer and with the battery removed, a battery with a X through it is on the screen, but it still wont turn on.

I have tried loads and loads of battery pulls with no luck at all.

Any help will be greatly appreciated. O2 are denying all responsibility so I need as much help as possible.

Thanks in advance guys.

Last edited by mikecoulthard : 02-05-2012 at 01:43 PM.
Offline   Reply With Quote