View Single Post
Old 08-26-2012, 07:52 AM   #8 (permalink)
dsigner
New Member
 
dsigner's Avatar
 
Join Date: Aug 2012
Model: 9900
PIN: N/A
Carrier: unknown
Posts: 3
Post Thanks: 0
Thanked 1 Time in 1 Post
Default Re: Nuked BlackBerry 9900, Reconnecting to JVM error !

Same situation as menoufy.
CAUSE:
Device was left charging overnight. Phone LED was continuously green. Removed from charger and it's only flashing the red LED since - i.e. what people call a infinite reset loop, otherwise known as "bricked" or "nuked".

Some said run apploader with /nojvm switch, then put in the battery when the device is trying to initialize to get over the reconnect to JVM error, but it still doesn't work. Tried numerous 'fixes' as the original poster with no success.

If I send it off to repair, they may do something to kickstart it. What is that solution, and how is it done? I'd rather do it myself and save 3 weeks of waiting to get my BB back. (I've cooked phone ROMs before, so have the tech-ability ;)

RESULTS OF INVESTIGATION:
For anyone else with similar problems - some other semi useful info:
The issue may be a combination of factors. I discovered my battery was faulty (I measured the voltage as 3.2V after leaving on the charger for a while, and not the 3.7v it should be). Though a new battery has no difference to the phone booting up properly, a faulty battery won't help.

The LED will flash on red for a few seconds, the flash duration I think could be proportional to the power, but not sure of the 'algorithm'. Currently sitting on the external charger: red LED on 2.7s, off 14.5s (these are averaged times over numerous manual timings). I've previously seen the LED on for much longer, perhaps as much as 10s when trying some of the different nuked recovery fixes.

I've had the phone show the charging battery symbol with no red LED flashing cycle (the external dock could potentially break the loop I'd read in a post somewhere, as it has only the electrical contacts).
Holding down the escape key while this symbol was on screen briefly showed the trackpad button light - which is the closest I've come to getting the device back. (Lookup booting in safe mode -as it could be app related, though apploader has previously reported the applications were erased). It thereafter went back to the red LED flash cycle.

Thousands of views on this thread, from others with similar problems I'm sure, so please add your experience and hopefully together we can solve this!

Hypothesis, if I can get the phone in the external charging dock connected to the PC (i.e. need 2 USB cables, one for phone->PC, one for charging_dock->wall_plug) with the charging symbol on the phone & no red LED flashing I could get the phone back??

...and no I haven't misused / abused the phone (dropped it / wet it / hacked it / etc)
Offline   Reply With Quote