View Single Post
Old 09-23-2012, 05:57 PM   #1 (permalink)
ivesremix
New Member
 
Join Date: Sep 2012
Model: 9850
PIN: N/A
Carrier: verizon
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Torch 9850 4 red blinking lights

Please Login to Remove!

I bought a Torch 9850 from ebay... The seller said it was in a boot loop. When I got it the thing would not turn on at all. The phone just blinks 4 red lights. I have pulled the battery, I have put another battery in it, I have left it charging for 4 hours, I have tried to restore via desktop manager and app launcher (computer will not detect the device) and I did try to pull the battery and put it back in while the drop down menu was open in app launcher where you select the device and still nothing, I have tried the jl_cmder and it also does not detect the phone. The odd thing is that if I plug the phone into a computer with no bb drivers installed I get the hour glass for a second on the mouse cursor and then it goes away. But with the bb drivers installed it does nothing at all. The phone does not seem to have any liquid damage. Is there any way to fix this other than sending it in for repair? I have heard it could be the boot/power ic but where is it on the motherboard and where do I buy a new one? Any suggestions on how I could fix this phone?
Offline   Reply With Quote