View Single Post
Old 03-06-2013, 05:40 AM   #1 (permalink)
Claidheamhmor
Thumbs Must Hurt
 
Claidheamhmor's Avatar
 
Join Date: Apr 2009
Model: 9810
PIN: N/A
Carrier: Vodacom
Posts: 52
Post Thanks: 0
Thanked 2 Times in 2 Posts
Default Unable to create users on BES10

Please Login to Remove!

I have a bit of a strange one here that's annoying me terribly.

I've installed BES10 (BDS 6.2) successfully. Port 3101 is open, SRP is connected. We're still on the 60-day trial, and I'm hoping we'll figure out sometime where I can actually buy a server licence (but that's besides the point). Port 443 has been opened too.

When I try to add a user to BES10, I can successfully find the user, but when I add the user, with or without activation password, I get the following error:
The BlackBerry® Administration Service was unable to create the required external authenticator for the user.

Searching for that error yields this page: KB32589-Unable to add specific Active Directory users to BlackBerry Device Service 6.2
After looking at that page, I checked the msExchMasterAccountSid; it exists on our user accounts in our resource domain, but the accounts are disabled, as they should be, and the mailboxes are linked to enabled accounts in our user domain which doesn't have that msExchMasterAccountSid attribute, so in theory, this is not applicable. The only accounts I can create on BES10 are for mailboxes that do not have the msExchMasterAccountSid attribute.

Does anyone have any idea about this?

Our environment:
BES 5.04 working 100% on a different server.
BES10 loaded on a Windows 2012 server on VMWare.
A user domain for user accounts.
A resource domain in a separate forest, where Exchange and mailboxes are hosted. Each mailbox has its own disabled account in the resource domain, and a user account from the user domain has rights to the mailbox.
Exchange 2010.
__________________
Claidheamhmor's BlackBerry Blog
Offline   Reply With Quote