View Single Post
Old 02-06-2007, 06:26 PM   #10 (permalink)
rivviepop
BlackBerry Extraordinaire
 
rivviepop's Avatar
 
Join Date: Dec 2006
Location: san francisco
Model: 8320
PIN: n/a
Carrier: t-mobile
Posts: 2,166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by antelope
"Bus 002 Device 009: ID 0fca:0006 Research In Motion, Ltd."

but again it's still not behaving like a modem although it does not automount after disabling mass storage on the phone :P
I had an exchange with the developer of Barry a bit ago when I was getting bcharge to work for the Pearl (see here: http://www.blackberryforums.com/gene...-charging.html) and it appears the problem is that the Pearl doesn't expose the modem portion of the interface immediately; you should see *two* entries in lsusb for the RIM device, one that's the mass storage and the other that's the ttyACM0 (sic) interface. Even if you set the Pearl to *not* use Mass Storage, it still presents the usb-storage interface when plugged in, which the kernel then grabs.

His one suggestion was to try actually removing (physically move the kernel module file) for usb-storage so that the kernel can't load it and see what happens; I have not tried this yet, just haven't gotten around to it. I'm just happy the thing charges right now at the proper 500mA with bcharge installed.

For management of data, I use SyncML for all my handsets; no need at all for desktop apps. See one of my posts here: http://www.blackberryforums.com/gene...tml#post422050
__________________
[ Linux & BlackBerry ] http://www.blackberryforums.com/linux-users-corner/
Offline   Reply With Quote