View Single Post
Old 02-07-2007, 06:16 PM   #14 (permalink)
rivviepop
BlackBerry Extraordinaire
 
rivviepop's Avatar
 
Join Date: Dec 2006
Location: san francisco
Model: 8320
PIN: n/a
Carrier: t-mobile
Posts: 2,166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by antelope
Tried removing usb_storage and loading cdc_acm... Even with the module not loaded (tried moving it too) it still shows up as just a mass storage device. No modem. Perhaps it needs more power first?
Try getting in touch with the Barry lead, he's really friendly and would love to hear about your progress (good or bad) I'm sure; you can reach him at cdfrey_at_ foursquare _dot_ net (Chris). He will probably have some things you could try (then let us all know ).

Quote:
I've heard that it works over Bluetooth, but maybe usb is different? ...I don't know, I'm just guessing
Yes, they're different -- BT exposes a 'profile', which you then connect to; I don't have a BT stack here at the office to show you, but basically you query a device and it returns all the profiles (file transfer, headsets, modem, etc.).

So whereas lsusb -v might show that one (and only one) device entry for the Pearl, when you do something similar over BT ("sdptool browse <BT mac address>") it'll return unique entries for each service. If I remember tonight I'll jack in my BT usb stick and play with it and post a set of profiles.
__________________
[ Linux & BlackBerry ] http://www.blackberryforums.com/linux-users-corner/
Offline   Reply With Quote