View Single Post
Old 02-11-2007, 11:49 AM   #19 (permalink)
rivviepop
BlackBerry Extraordinaire
 
rivviepop's Avatar
 
Join Date: Dec 2006
Location: san francisco
Model: 8320
PIN: n/a
Carrier: t-mobile
Posts: 2,166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by antelope
I've tried different AT commands but am still getting the same result. Perhaps its a misconfiguration on my end. anyone have a wvdial conf or the correct init strings for this phone/service?
I *think* that the init strings are all the same, in that it's something to do with GSM dialing and not quite like a real modem (where different models might have different inits). Given that, I can supply my S60/Symbian values that might be relevant.

/etc/wvdial.conf
Code:
[Modem0]
Modem = /dev/rfcomm0
Baud = 115200
SetVolume = 0
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM0
FlowControl = CRTSCTS
[Dialer TMobile]
Username = t-mobile
Password = t-mobile
Phone = *99#
Stupid Mode = 1
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 =  at+cgdcont=1,"IP","wap.voicestream.com"
Inherits = Modem0
Notice that the last parameter in Init3 might be different depending on your plan with your carrier -- 'wap.voicestream.com' is suitable for the BlackBerry data plan on T-Mobile. Also, the Modem=/dev/rfcomm0 I think might be for when I use it with a USB cable, not a BT stack.
__________________
[ Linux & BlackBerry ] http://www.blackberryforums.com/linux-users-corner/
Offline   Reply With Quote