View Single Post
Old 06-14-2007, 01:53 PM   #25 (permalink)
NinjitsuStylee
New Member
 
Join Date: Jun 2006
Location: Chicago
Model: 8100
Carrier: Tmobile
Posts: 7
Post Thanks: 0
Thanked 0 Times in 0 Posts
Angry Segmentation Fault?

Does anybody know what's going on here?

Every time I try to encode a video I get a segmentation fault.

Here's the output:

MEncoder 1.0pre8-4.0.3 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2200+ (Family: 6, Model: 8, Stepping: 0)
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled with runtime CPU detection.
success: format: 0 data: 0x0 - 0x15cc1800
AVI file format detected.
VIDEO: [XVID] 624x352 12bpp 23.976 fps 999.3 kbps (122.0 kbyte/s)
[V] filefmt:3 fourcc:0x44495658 size:624x352 fps:23.98 ftime:=0.0417
================================================== ========================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
================================================== ========================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [scale w=240 h=135]
================================================== ========================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
================================================== ========================
VDec: vo config request - 624 x 352 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.

SwScaler: BICUBIC scaler, from Planar YV12 to Planar YV12 using MMX2
videocodec: libavcodec (240x136 fourcc=34504d46 [FMP4])
Writing header...3f ( 0%) 0.00fps Trem: 0min 0mb A-V:0.008 [0:0]
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.
Pos: 0.9s 22f ( 0%) 0.00fps Trem: 0min 0mb A-V:0.086 [0:63]
Skipping frame!
Pos: 3.0s 73f ( 0%) 53.64fps Trem: 12min 76mb A-V:0.084 [316:64]
Skipping frame!
./vid2bb.sh: line 25: 19491 Segmentation fault mencoder "$FILE" -o "${FILE%.*}_bb.avi" -of avi -ovc lavc -oac lavc -lavcopts vcodec=mpeg4:vbitrate=$VBR:acodec=mp3:abitrate=$AB R -vf scale=$RES




I'd really love to use this script, as it seems like the most simple solution to encoding files for the BB. I use an 8100 (Pearl) and I'm trying to do a 16:9 video.
Offline   Reply With Quote