View Single Post
Old 05-29-2005, 11:32 PM   #1 (permalink)
stonedberry
New Member
 
Join Date: May 2005
Model: 9700
Carrier: Rogers
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Unable to connect to database ...

Please Login to Remove!

Hello everyone!

The installation of BES 4.0 has been a nightmare.

The documentation is very poor (especially on the database portion)...

I could not find any documentation on the Blackberry website which resolved my issue... although I stumbled onto this great forum and found this thread.

I have been in contact with my service provider who then routed my call to a RIM support specialist. I have been in contact with RIM for over three days now and they have not been able to resolve my issues.

I am hoping that someone who has had similar issues may be of some help to me by providing me some tips/tricks or procedures on how to resolve my issue.

I have tried the setup using different scenarios as explained below:

Scenario 1

- BES 4.0 installed on a Windows 2000 Advanced Server with Service Pack 4.0
- The BES Server was running MDAC 8.0 and the CDO.DLL; MAPI32.DLL; where the correct version
- The BES Server also had the Microsoft Exchange Administrator loaded with the latest version recommended by RIM - This was identical to the version on the Microsoft Exchange Server 5.5 Server (This server is running Microsoft Windows NT 4.0 SP6a)
- Both the BES and Exchange are in the same domain (NT)
- User was created BESAdmin (Domain User (tried Domain Administrator as well); Log on locally and Log on as a Service where also added for the BESAdmin user account, the BESAdmin account was added to the local Administrators group on the BES Server
- Microsoft SQL Server 2000 SP3a was loaded on an external server (Windows 2003) which was on an AD 2003 (trust relationships between AD and NT Domains).
- I was able to connect to the Blackberry Manager at times and sometimes it would give me the "Unable to connect to database" error. (This was resolved by restarting both the BES and SQL Server).
- I was not able to activate any RIM device wirelessly. The password would be sent to the local inbox in exchange but it would not forward to the RIM
- Desktop Redirector via BES also did not work
- BBSRPtest also was working
- The BES 4.0 was installed using the BESAdmin account

After many troubleshooting sessions with RIM and many database rebuilds and BES re-installs they decided to install the MSDE database on the BES server to rule out the fact that the SQL database was on another domain.

MSDE on the BES also provided the same issue: the blackberry could not activate locally via software or via wireless enterprise activation. E-mail would be sent to the inbox of the local exchange account but it would not forward to the RIM device at all.

Scenario 2

- BES Server 4.0 installed on new server with Microsoft Windows 2000 Advanced Server on the SAME domain as our Exchange 5.5 NT 4.0 SP6a Server
- Microsoft SQL Server 2000 SP3a was also installed on the BES Server
- SQL Server was installed first with BESAdmin account
- Microsoft Exchange Administrator with SP4 updates was installed
- BES 4.0 was installed last
- This time I received the "UNABLE TO CONNECT TO DATABASE!"
- I tried to re-install both BES and SQL but no luck
- I made sure that both TCP/IP and Named Pipes where enabled for both Server and Client network connectivity
- I also made sure that the CDO.DLL And MAPI32.DLL file where the correct versions and both matched the Exchange Server
- The BESMgmt Database had the proper configuration and the authentication was Windows (tried SA as well)
- SQL Server Service was tested with Local System Account as well as the BESAdmin account (same "unable to connect to database error".
- I tested database connectivity in the BES Manager Configuration and it was OK
- All other BES utility tests confirm everything is fine

Can someone please help me and provide me with some tips or procedures?

I am not sure if I have not done something correctly or if the database permissions are incorrect or I am missing something...

RIM has gone over many troubleshooting steps and I have also sent them the logs but they are still stumped.

Any help would be greatly appreciated.

Thanks again!
Offline