View Single Post
Old 07-25-2007, 12:16 PM   #51 (permalink)
AbuAnsar
Knows Where the Search Button Is
 
Join Date: Jul 2007
Model: 8100
PIN: N/A
Carrier: T-Mobile
Posts: 17
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

another day of hard working desperately trying to make my BB 8100 act as a modem in Ubuntu 7.04...

$ dmesg still doesn't show that the device is located in /dev/rfcomm0

I found out how to bind channels to rfcomm by typing:

$ sudo rfcomm bind 00:0F:86:F6:31:92 channel 1

$ sudo rfcomm -a
rfcomm0: 0C:00:00:00:00:00 channel 1 clean


(but why istead of 00:0F:86:F6:31:92, rfcomm0 shows 0C:00:00:00:00:00 ?) Is it supposed to be clean? what should I do next?

Well, when I tried channel 4 and channel 5,
$ sudo rfcomm bind 00:0F:86:F6:31:92 channel 4
it retuns this: Can't create device: Address already in use

I'm not sure if I bound channel 1 to rfcomm correctly but anyway I tried wvdial

~$ wvdial
--> Ignoring malformed input line: "Baud 460800"
--> WvDial: Internet dialer version 1.56
--> Cannot open /dev/rfcomm0: Host is down
--> Cannot open /dev/rfcomm0: Host is down
--> Cannot open /dev/rfcomm0: Host is down


I think I didn't bind the channel(s) with rfcomm in a proper way and then didn't configure wvdial properly either.

Guys please help me !
Offline   Reply With Quote