View Single Post
Old 07-27-2007, 07:37 AM   #41 (permalink)
sems
Thumbs Must Hurt
 
Join Date: Jan 2006
Model: 8800
Carrier: Cingular
Posts: 72
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

Quote:
Originally Posted by RipThorn View Post
Hi Gary

I think i found out what the problem is

when adding permission you use the following line
get-mailboxserver <mail_server_name> | add-adpermission –user BESAdmin –accessrights ExtendedRight –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

the line that works for me is
get-mailboxserver <mail_server_name> | add-adpermission –user BESAdmin –accessrights Genericread, GenericWriteExtendedRight –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin

only after adding Genericread and genericwrite my MAPI errors went away

thank you
On a test bed we have, I keep on getting MAPI error, "Bookmark is not valid". I checked besadmin user's global address list priviliges via ADSIEdit, I tried apply what RipThorn has written, still no dice. The error occurs when I try to run Blackberry Manager or edit MAPI profile for Blackberry Server.

Any suggestions?
Offline   Reply With Quote