View Single Post
Old 11-06-2007, 04:05 AM   #73 (permalink)
hitty
Thumbs Must Hurt
 
hitty's Avatar
 
Join Date: Jun 2006
Model: 9780
Carrier: Vodafone UK
Posts: 71
Post Thanks: 2
Thanked 2 Times in 2 Posts
Default Permissions not working with BES 4.1.4 on Exchange 2007

Hi
Our clients BES 4.1.4 on Exchange 2007 and was working fine, except for a calendar issue.
We recommended checking whether the BESAdmin user was a domain admin. It was, and so they removed it.
After it was removed, they restarted the BES, then nothing worked at all (i.e. no e-mail to phone).
We checked and redid the permissions as per the BlackBerry KB12483

get-mailboxserver <mail_server_name> | add-adpermission –user BESAdmin –accessrights Genericread, GenericWrite –extendedrights Send-As, Receive-As, ms-Exch-Store-Admin
No luck.

We then setup an entirely new BES on an entirely new machine with an entirely new user, again *Nothing* worked (i.e. no e-mail to phone).
We then reverted back to the original BES. If we add back BESAdmin into the domain admin groups, we get e-mail to the device again, but the calendar syncing does not work properly.
Exchange Mapi Client and CDO 1.2.1 is installed on the BES.

Whenever BESAdmin is NOT in the domain admin group, we get a MAPI error that we have below:
MAPIMailbox::CreateSearchFolder - Open Entry (0x80070005) failed
If It IS, it works OK (apart from the calendar syncing).

SRP shows Connected
BlackBerry Services are all running fine with the correct login
Components NOT working: mail inbound, mail outbound, PIM data contacts and tasks, PIM data calendar

Result of IEMSTest
C:\Program Files\Research In Motion\BlackBerry Enterprise Server\Utility>IEMSTes
t.exe
BlackBerry Enterprise Server Utility - IEMSTest.exe (IExchangeManageStore), Vers
ion 1.0
Copyright (c) Research In Motion, Ltd. 1999. All rights reserved.
Opening Default Message Store Mailbox - BESAdmin2.
Opening message store for test user using /o=MBR/ou=first administ
rative group/cn=Recipients/cn=test /o=MBR/ou=Exchange Administrative Group (FYDI
BOHF23SPDLT)/cn=Configuration/cn=Servers/cn=BOOTHOME/cn=Microsoft Private MDB.
test users Mailbox opened successfully.
Root Folder opened successfully.
Failed to create a folder in test users mailbox.

Can anyone please provide assistance?
Thanks
Offline   Reply With Quote