View Single Post
Old 11-16-2007, 04:53 PM   #1 (permalink)
DeanQ
Knows Where the Search Button Is
 
Join Date: Sep 2006
Model: 8100
Carrier: tmo
Posts: 31
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Tmo curve = worst bluetooth phone ever

Please Login to Remove!

Ok, what is up with this POS phone. I love the phone, but jesus the bluetooth is a piece or garbage. I have a Plantronics 645 or 655 . It's only a yr old. It pairs up fine with my 8100 pearl. It took no time to pair up. It was easy as pie. Nope, the Curve won't pair no matter how many time I keep entering the correct bluetooth key. It sees it but wont take it. I saw a thread before and a few people complained about the same exact issue. I bought a new bluetooth headset today. The blueant Z9. Same crap. After a reboot and constant trying it finally paired. But it keeps dropping off and on randomly. At one time, I got the plantronics to work once in the past. And when it did connect it did the same crap. Constant dropping for no reason. You people with the TMO curves are you having any bluetooth issues or is everything working flawlessly. Zero drops? Was pairing simple that took only one minute? If so, what brand headset are you running? I have the newest .180 os loaded. I had this issue with the original TMO os then the next upgrade and now the .180. I am so mad. I spent $80 for a headset that is doing the same crap. I guess my next option is to call TMO for a new phone. That cant be it since other user reported the same crap.


When I say dropping I don't mean while making a call. Just the bluetooth headset not seeing the phone and connecting and reconnecting.

Last edited by DeanQ : 11-16-2007 at 04:59 PM.
Offline   Reply With Quote