View Single Post
Old 12-05-2007, 10:41 AM   #15 (permalink)
sapter5361
New Member
 
Join Date: Jun 2006
Location: New York
Model: 8320
Carrier: T-Mobile
Posts: 12
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Had the same problem

I had the same error message on one of my routers (linksys WRT54G), and after extensive troubleshooting found it to be a relatively simple thing to fix: my router had 'mac filtering' enabled under wireless security (it allows only the devices listed on the 'mac list' to connect. So I looked up my blackberry mac address (Options>Status>WLAN MAC), added it to the list of allowed mac addresses on the router, restarted the router, and PROBLEM SOLVED.

Hope this helps.

Also, always make sure that you have the two wifi service books on your bb. I didn't have it in the beginning and tmobile had to resend them.

Service Books Needed for WiFi to work on bb:

* Wi-Fi TCP/IP Browser [BrowserConfig] - Controls Internet browsing over Wi-Fi.
* Wi-Fi TCP/IP Transport [WPTCP] - Controls calls over Wi-Fi (T-Mobile HotSpot @Home service).
Offline   Reply With Quote