View Single Post
Old 12-23-2007, 02:42 AM   #1 (permalink)
GuardianOfAura
New Member
 
Join Date: Dec 2007
Location: South West Florida, USA
Model: 8320
PIN: N/A
Carrier: T-Mobile
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Windows Vista driver issues?

Please Login to Remove!

Hello all. I'm completely perplexed at this problem. Maybe someone can assist.

I have an 8320 Curve from T-Mobile. I'm running v4.3 of the Desktop Software, and 4.2.2.180 firmware on the phone. My PC is a custom-built machine (by me), running Windows Vista Ultimate, 32-bit edition. The problem I'm having is that Vista doesn't seem to know what to do with my 8320. I am able to access device memory (SMS chat logs, internally-stored media, etc), but the microSD, aka "media card" is totally inaccessible. Sort of...

When I first connected my 8320 to the PC, Vista detected three devices. RIM Composite Device, and two virtual serial ports (v3 and v4). Desktop Manager refused to detect the device, and Vista couldn't find drivers. I spent 3 hours on the phone with RIM's technical support line, and the best advice they could offer was "reboot your PC."

I did some digging around, and managed to "force" a USB driver into "RIM Composite Device." The driver is located at c:\program files\common files\research in motion\usb drivers

After doing this, Desktop Manager was able to detect the device + device memory. But this is where it gets -strange-

I set the BlackBerry to prompt me for mass storage access when a USB cable is connected. When I plug the phone into the PC, I get the "yes / no" pop-up on the phone. If I do NOT give it any answer (i.e. leave it there), Media Manager is able to access the files on the media card - sometimes. Half the time, it won't even access. The other half of the time, it'll access the files, but they'll appear corrupt. And I -never- get a drive letter in My Computer, like I used to on XP. And if I give it any answer (yes to enable mass storage, or no), the icon for the media card completely disappears from Media Manager - regardless of the answer I give it!

Here's a brief run-down of the steps I took:

1) Installed Vista32 to blank hard disk.
2) Installed all critical OEM drivers (motherboard, etc)
3) Downloaded all Vista updates + latest drivers
4) Installed BlackBerry Desktop Manager 4.3
5) Rebooted
6) Connected 8320 to PC via USB cable.
7) Used a handful of choice phrases and colorful metaphors.
8) Forced USB driver onto "unknown" device
9) Flashed 8320 firmware with "latest and greatest" version available

Any help would be greatly appreciated. :D Thank you kindly in advance.

Regards,
Will
Offline   Reply With Quote