View Single Post
Old 02-14-2008, 06:05 PM   #12 (permalink)
nigglesworth
New Member
 
Join Date: Jan 2008
Model: 8800
PIN: N/A
Carrier: Fido
Posts: 4
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default still not working.

Since my last post, I have taken the entire phone apart and cleaned it out. I was hopping to find some kind of debris or obstruction in the key pad... but nothing. The problem will happen with or with out the trackball in place.

I checked the spring on the wheel ( kusellout69's suggestion). As far as I can tell, there is no spring switch on the circuit board itself. Is this correct?

It has not gotten wet, but has been carried in my pocket from time to time. I have tried every fix I can find with no luck. Does this mean my circuit board is fried/shorted? It is not much use to me in this condition.

I would also like to know if it is worth fixing/ or replacing.

Any input would be greatly appreciated!

I also have to agree with kusellout69, that I am not hot on the idea that I have to baby a $400 phone.

Thanks everyone
Offline   Reply With Quote