View Single Post
Old 06-10-2008, 09:42 PM   #8 (permalink)
rivviepop
BlackBerry Extraordinaire
 
rivviepop's Avatar
 
Join Date: Dec 2006
Location: san francisco
Model: 8320
PIN: n/a
Carrier: t-mobile
Posts: 2,166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by alvin_a_garcia View Post
Thanks for the suggestion; I had actually thought about this after my previous posting. Well, I tried it, and yes, I am able to successfully read the JPEG photos on the MicroSD card if I mount it via a card reader. So, something is FUBAR with the USB connection, at least under Linux.

Hmmm ....
Hmmm indeed - at least knowing where to start digging is half the battle. Alas, my device doesn't have the newer operating system like yours, but I don't think that's it - a little google-fu show that other people have the 8130 working, mainly with Ubuntu.

Just out of curiosity, have you tried swapping the cable, trying a different USB port, not using a USB hub, and other hardware switchups like that? Also there is a bug in F8 ("fixed" in F9) where the BB crashes/reboots when plugged into an external USB hub but works fine when plugged directly in to a machine.

One thing you could also look at - there's a module called 'berry_charge' that messes with the USB mass storage sometimes; you could try unloading that module (rmmod berry_charge), then locate it on disk and physically rename the file so it won't load when you plug in your 8130; it lives in /lib/modules/<kernel version>/kernel/drivers/usb/misc/berry_charge.ko physically. Then try plugging in your 8130 and see what happens...
__________________
[ Linux & BlackBerry ] http://www.blackberryforums.com/linux-users-corner/
Offline   Reply With Quote