View Single Post
Old 06-10-2008, 10:08 PM   #9 (permalink)
alvin_a_garcia
New Member
 
Join Date: Jun 2008
Model: 8130
PIN: N/A
Carrier: Verizon Wireless
Posts: 9
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rivviepop View Post
Hmmm indeed - at least knowing where to start digging is half the battle. Alas, my device doesn't have the newer operating system like yours, but I don't think that's it - a little google-fu show that other people have the 8130 working, mainly with Ubuntu.

Just out of curiosity, have you tried swapping the cable, trying a different USB port, not using a USB hub, and other hardware switchups like that? Also there is a bug in F8 ("fixed" in F9) where the BB crashes/reboots when plugged into an external USB hub but works fine when plugged directly in to a machine.

One thing you could also look at - there's a module called 'berry_charge' that messes with the USB mass storage sometimes; you could try unloading that module (rmmod berry_charge), then locate it on disk and physically rename the file so it won't load when you plug in your 8130; it lives in /lib/modules/<kernel version>/kernel/drivers/usb/misc/berry_charge.ko physically. Then try plugging in your 8130 and see what happens...
Hello,

Thanks very much again for your suggestions. I have tried the different things you've suggested: different USB ports, I don't have a USB hub, and I have berry_charge in my modprobe blacklist file so that this kernel module doesn't get loaded. I've also tried this on a different computer, which is using a much older linux distro (Scientific Linux 3(?), which is a respin of Red Hat Enterprise Linux 3), and with a different USB cable. Same thing there.

Very, very strange. If not for the fact that I can properly read over USB under MS Windows, I would think that my phone is somehow fubar.

Thanks again for all the suggestions.
Offline   Reply With Quote