View Single Post
Old 06-11-2008, 10:29 AM   #1 (permalink)
Mikle
New Member
 
Join Date: Jun 2008
Location: Rockville, MD
Model: 8320
PIN: N/A
Carrier: Tmobile
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Cool BES and Domino on different Notes domains - problem

Please Login to Remove!

I apologize for the long story but I need to explain it properly and that is the reason why this post became a novel.

I have two Domino servers in different Notes domains. The server A is Domino 7.0.3 (the name is ServerA/Acme1) and the server B is 6.5.4. (the name is ServerB/Acme2). Both servers are on Win2003 standard.
The servers are cross-certified, the replication of NABs and mail routing between the domains is working without any problem.
The third Domino server (7.03 on Win2003R2) is server which name is Blackberry/Acme1 (in the same domain with the Server A) and it hosts BES ver. 4.1.5.33.
The Blackberry Manager I use for BES administration is ver. 4.1.5.26

The BES is working almost perfectly with the ServerA/Acme1.
(Later on, I will explain why I said almost perfectly)

Following the documentation, which says that BES 4.1 versions support Domino multi domain environment, I set the Blackberry/Acme1 and the ServerB/Acme2 to be cross-certified, I set ACLs on both sides and I have done all the things according to the administration guide.. and finally I have added the first user from the domain Acme2 to BES. The whole process passed smoothly and that user account still works perfectly.
A week later, I wanted to add another user from the domain Acme2 to the BES and then I faced the problem.

When I tried to add the user and when I tried to choose the ServerB/Acme2 (I actually typed the server name) I got the message:
"Unable to find path to server. To trace this connection, use File - Preferences - User preferences - Ports - Trace (Notes client) or Trace command (Domino server)"

I checked the Domino servers, both of them (Blackberry/Acme1 and ServerB/Acme2) were working OK, the connection documents were there, the replication between them was OK, trace command on both servers was OK ... and the user from the domain Acme2 who was previously added works fine.

I tried to make a simulation and to add the user from the ServerA/Acme1 (from the same Domino domain). I chose the server from drop-down list but I got the same error message:
"Unable to find path to server. To trace this connection, use File - Preferences - User preferences - Ports - Trace (Notes client) or Trace command (Domino server)"

Next, instead of to choose the ServerA/Acme1, I typed the IP address of the ServerA, the Blackberry Manager found the ServerA and I could pick the user from that server. After that, I could enter ServerA name and I could get the user list but just until I am in the same session with Blackberry Manager. If I close Blackberry Manager and open it again, I get the same message “Unable to find path to server…” Entering the IP address instead of the name “fixes” that problem.
That is the reason for why I said above, that the ServerA/Acme1 is working almost perfectly with Blackberry/Acme1.

When I tried to do the same with the ServerB/Acme2 (to type the IP address instead of the ServerB name) I got the message:
"Your Address Book does not contain any cross certificates capable of authenticating the server."

I checked all the things again on both Domino servers, recertified them, checked connection documents, restarted them several times, and nothing shows me that the problem is with the connection or cross-certification. The servers work OK, and they “see” each other. The trace command is working OK as well.
And interesting thing is that the user from domain Acme2, who was added at the first attempt (a week ago) runs without any problem… but I cannot add any user again from the domain Acme2.

The guys from local BES support could not find the solution so I decided to post this problem here.
Everyone with the idea how to fix this problem is very welcome!

Last edited by Mikle : 06-11-2008 at 11:00 AM. Reason: Mistake in the title
Offline   Reply With Quote