BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 11-10-2007, 09:03 PM   #1 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Gmail with Rogers $65/1GB plan

Please Login to Remove!

Hey all. I just got my 8310 today, a very nice piece of equipment. ;)


Anyway. I've set up this blackberry on a generic data plan with Rogers. I've got the APN entered as what the tech support guys told me (APN internet.com, user wapuser1, pass wap), and I've installed Opera through the desktop manager, it works fine.

However, seemingly no matter what I do, I cannot get the gmail mobile app to stop telling me "network unavailable: this program requires a data connection..." I've triedd both an older beta version and 1.1.0 installed through the desktop manager.

Any ideas as to what I might be doing wrong? Something seems fishy considering that Opera works like a star.
Offline  
Old 11-10-2007, 09:08 PM   #2 (permalink)
Grumpy Moderator
 
NJBlackBerry's Avatar
 
Join Date: Aug 2004
Location: Somewhere in the swamps of Jersey
Model: i5s
Carrier: AT&T
Posts: 27,803
Post Thanks: 33
Thanked 442 Times in 382 Posts
Default

Welcome to BB Forums.

The FAQ here - Carrier specific APN/TCP settings - BlackBerryFAQ - has different settings. I'd give them a try.
Offline  
Old 11-10-2007, 10:04 PM   #3 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yep, I've tried just internet.com too, no luck. Interestingly enough it still does work with Opera when I change the APN settings to that.

For a bit more info on what is happening...gmail transmits and receives a whole bunch of data while "loading", then eventually just gets stuck on loading with no data transmitting, and then I get the "network unavailable" message. Also, if I do this and get that message, it seems that Opera sometimes works only intermittantly from then on.
Offline  
Old 11-10-2007, 10:31 PM   #4 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Oh, other things I've tried:

Setting TLS to handheld instead of proxy, that didn't do anything.
Reimaging the device, again did nothing.
Resetting the network config inside of gmail, nothing.
Ensuring the gmail app has "allow" privileges to everything listed in security, again nothing.

Any other ideas? I really don't want to have to go to a real blackberry plan...$65/1GB vs $60/25MB is just a little bit crazy.
Offline  
Old 11-11-2007, 11:07 AM   #5 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hm. Something else strange to note. I've never had a full blackberry plan, yet I can access the BB browser and do OTA installs - sometimes. I wonder if my account is provisioned incorrectly and so Gmail is trying to connect through the BIS or something...
Offline  
Old 11-11-2007, 11:51 AM   #6 (permalink)
Thumbs Must Hurt
 
Join Date: Aug 2006
Model: 8310
Carrier: Rogers
Posts: 193
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

see if this helps:

HOWTO: Use BlackBerry on Generic NON-BlackBerry Data Plan
__________________
Rogers SAME DAY UNLOCKING Service: $16 !!!
T-Mobile Unlocks: $24
AT&T / Cingular Unlocks: $14.99
My Feedback
Offline  
Old 11-11-2007, 12:41 PM   #7 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

That was the exact thread that I used to install gmail, I downloaded the cods from there, made my alx, and installed it through the desktop manager.

Also I just phoned rogers, they say they can't see anything wrong with my account.

Also, I am running 4.2.2.163, would it perhaps help if I wiped the device and installed the 4.2.2.181 from SunCom Wireless that is listed on the 8300 forums?
Offline  
Old 11-11-2007, 01:51 PM   #8 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 6
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've tried upgrading the OS now to the SunCom wireless version. No difference. I'm this close to just giving up and losing most of my data to move to a 25MB blackberry plan. :(
Offline  
Old 11-22-2007, 10:06 AM   #9 (permalink)
New Member
 
Join Date: Nov 2007
Model: 8310
PIN: N/A
Carrier: Rogers
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Gmail with Blacberry

remove the service boooks (from our old BIS service with them) from your device and your Gmail should work
Offline  
Old 02-15-2009, 10:57 PM   #10 (permalink)
New Member
 
Join Date: Dec 2008
Model: 8130
PIN: N/A
Carrier: sprint
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

How bout new ALX/COD files? Here's a link to Gmail 2.0.6:

rapidshare.com/files/178923988/GoogleMail_2.0.6_for_BB.zip
Offline  
Old 02-16-2009, 02:12 PM   #11 (permalink)
Talking BlackBerry Encyclopedia
 
makedonce's Avatar
 
Join Date: Aug 2007
Location: Skopje, Macedonia at the moment
Model: 8900
OS: 5.0.348
PIN: 24AE6BA3
Carrier: T-mobile MK
Posts: 464
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have acess to BB browser and can do OTA, but no BB plan. Why don't you go to m.google.com and install the gmail app from there OTA. The latest version is 2.0.6
__________________
BB Support rule #1: When in doubt, pull it out..... (the battery)


http://www.twitter.com/petarnikoloski
Offline  
Old 02-17-2009, 06:14 AM   #12 (permalink)
CrackBerry Addict
 
JaguarXJ7's Avatar
 
Join Date: Nov 2005
Location: Halifax
Model: 9810
OS: 7.1.0.714
Carrier: Rogers
Posts: 554
Post Thanks: 4
Thanked 0 Times in 0 Posts
Default

Wirelessly posted

^^ that's what I was thinking. Install OTA; likely an issue with the files you installed. Should probably remove currently installed files.
__________________
Regards, Jag

"Torch 9810 + Playbook 64gb"
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.