BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 09-29-2008, 02:27 PM   #1 (permalink)
Thumbs Must Hurt
 
Join Date: Mar 2006
Model: 8100
Carrier: t-mobile
Posts: 54
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default possible fix - softreset & os 4.5

Please Login to Remove!

For those of you who either cant get softreset to work with the existing workaround (alter and open up your default permission on the device) or are unwilling to do that I did a little bit of thinking and came up with this - it works on my device (pearl, tmobile, 4.5.92) just need someone else to try it

* make sure that softreset is installed, firewall is enabled, and softresets firewall prompts are reset
* run softreset - attempt reset - grant it trusted application status - as well as aa_DeleteToReset (it should fail with the usual unexpected bit at this point)
* disable the firewall and try to run softreset and reset again (should work this time, but select reboot later)
* go edit the permissions on the module aa_DeleteToReset and edit the connections one to allow, save and reenable the firewall
* delete the module aa_DeleteToReset and allow the device to restart

Softreset should work as normal now - if someone has the time be great to narrow it down to the specific connection it wants and just allowing that one
Offline  
Old 09-29-2008, 02:58 PM   #2 (permalink)
BlackBerry Extraordinaire
 
Helmdawg's Avatar
 
Join Date: Jan 2007
Location: Philly
Model: 9700
OS: 5.0.593
PIN: ned down...
Carrier: T-Mobile
Posts: 1,365
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

This does work, I posted this a few months ago here. Thanks for re-posting because I don't think many folks know that it can work with 4.5

Keyboard / external shortcuts question
Offline  
Old 09-29-2008, 04:03 PM   #3 (permalink)
BlackBerry Extraordinaire
 
Redflea's Avatar
 
Join Date: Jan 2008
Model: 8130
OS: 4.5.0.131
PIN: N/A
Carrier: Verizon
Posts: 1,598
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

FYI - I've been using softreset w/4.5 w/out any problems.

I just reset my Peal 8130, on OS 4.5.0.77, right now using softreset. Works, no problem, no work-arounds required.
Offline  
Old 09-29-2008, 04:11 PM   #4 (permalink)
BlackBerry Extraordinaire
 
Helmdawg's Avatar
 
Join Date: Jan 2007
Location: Philly
Model: 9700
OS: 5.0.593
PIN: ned down...
Carrier: T-Mobile
Posts: 1,365
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Redflea View Post
FYI - I've been using softreset w/4.5 w/out any problems.

I just reset my Peal 8130, on OS 4.5.0.77, right now using softreset. Works, no problem, no work-arounds required.
When i first installed OS 4.5 I was getting uncaught exceptions as well as many others folks here. Could be your permissions were already set to work with 4.5. Either way, i'm glad it works. Great little app.
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.