BlackBerry Forums Support Community
              

Closed Thread
 
LinkBack Thread Tools
Old 06-17-2010, 09:37 AM   #161 (permalink)
New Member
 
Join Date: Oct 2008
Model: 9700
PIN: N/A
Carrier: Telus
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Please Login to Remove!

I'm on Telus..Bold 9700 on HSPA. Connects perfect to my asterisk box and makes calls BUT cannot hear anything on either end.
Offline  
Old 06-17-2010, 03:11 PM   #162 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

[quote=tifa2009;1619400]
Quote:
Originally Posted by Aviator168 View Post
BlackVoib has been updated.

The current version is 0.56.

Users now can toggle between speaker phone and handset(from menu). The volume control also has been added. Just use the volume control when the main screen is on top.





pleaseeeeeeeeeee guys how i can install the blackvoib.jad on my blackbeery ???????????

the only way i successed to install is by the bb direct

please help
Open BlackBerry Browser then goto http://www.blackvoib.com/Download/BlackVoib.jad
Offline  
Old 06-17-2010, 03:14 PM   #163 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by japostol View Post
I'm on Telus..Bold 9700 on HSPA. Connects perfect to my asterisk box and makes calls BUT cannot hear anything on either end.
I guess HSPA is your data service. Am I correct on this?

Did you specify a stun server? Also, you might have set NAT=yes in the user definition in sip.conf.
Offline  
Old 06-17-2010, 03:20 PM   #164 (permalink)
New Member
 
Join Date: Oct 2008
Model: 9700
PIN: N/A
Carrier: Telus
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes to HSPA and yes to NAT.

I didn't set a STUN server, wasn't sure what it was. I don't believe we use one??
Offline  
Old 06-17-2010, 04:05 PM   #165 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by japostol View Post
Yes to HSPA and yes to NAT.

I didn't set a STUN server, wasn't sure what it was. I don't believe we use one??
Should also set one if behind router/firewall. Try stunserver.org
Offline  
Old 06-17-2010, 05:26 PM   #166 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

ALX files for BlackVoib installation from BlackBerry Desktop Manager are now available. Go direct to bottom of page BlackVoib.
Offline  
Old 06-18-2010, 09:39 AM   #167 (permalink)
New Member
 
Join Date: Oct 2008
Model: 9700
PIN: N/A
Carrier: Telus
Posts: 10
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Aviator168 View Post
Should also set one if behind router/firewall. Try stunserver.org
Tried stunserver.org and same thing. Anyone have any suggestions?
Offline  
Old 06-19-2010, 03:59 AM   #168 (permalink)
New Member
 
Join Date: Jun 2010
Model: 8520
PIN: N/A
Carrier: Globe Telecom
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Aviator168,

I just wanted to ask if the BlackVoib application will work with TPad. I'm currently subscribed to Tpad. Thanks.
Offline  
Old 06-20-2010, 06:53 PM   #169 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by moks1972 View Post
Hi Aviator168,

I just wanted to ask if the BlackVoib application will work with TPad. I'm currently subscribed to Tpad. Thanks.
I created a tpad account and make the 121 call. Worked fine. I was not ablt to make calls between two tpad accounts. Even with xlite.
Offline  
Old 06-21-2010, 04:22 AM   #170 (permalink)
New Member
 
Join Date: Jun 2010
Model: 7100T
PIN: N/A
Carrier: Tpad
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Tpad SIP Settings for Blackberry Generic SIP Client

Hi,

We are going to test this client soon with Tpad, in the meantime these settings may help.

Tpad SIP Settings:

Local SIP port : 5060 (or alternative 8891 or 8791 or 80)
Registrar : sip.tpad.com
Proxy server : sip.tpad.com (or alternative sipx.tpad.com)
Domain : sip.tpad.com (or alternative sipx.tpad.com)
Realm : sip.tpad.com (or alternative sipx.tpad.com)
Outbound proxy server : sip.tpad.com
Account name : Your 7 digit Tpad IN Number (found in your Tpad Team Email)
Authorised User ID: Your 7 digit Tpad IN Number
Password : Your Tpad password (found in your Tpad Team Email)
Display name/number : Your Tpad IN Number

Stun server (optional) : Leave Blank
but if you have problems then use

For Softphones (Xlite) use this settting

stun.fwdnet.net:3478
stun.tpad.com:5060
stun.tpad.com:3478

For IP Phones / ATA's ths this setting

STUN Server: stun.fwdnet.net (or alternative stun.tpad.com)
STUN's Port:3478

Registrar Expire : 3600 seconds / 60 mins

Tpad Compatible Codecs :
G.711 (G.711a / G.711u) = (64 kbps)
PCMU / PCMA = (64 kbps)
G729 (low bandwidth)

If you need any more help then send me a PM.

Regards

Tpad
Offline  
Old 06-21-2010, 09:15 AM   #171 (permalink)
New Member
 
Join Date: Jun 2010
Model: 8900
PIN: N/A
Carrier: Wind
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Great !

hi, i've installed blackvoib and all work great (even if sometimes it crashes and i've to reboot the blackberry) !!!
i can call with all my betamax voip account ( but only with my next-door neighbor wlan, not my own ) and i can receive call, nice !
what can i do to use blackvoib with my own wlan ? i already use a stun server.
are there any port to open on my router ?
blackvoib can connect but every time i place a call it fail...
thank you and great work !
Offline  
Old 06-21-2010, 10:33 AM   #172 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

cmpmcl,

Definitely a router issue. Do you have incoming UDP ports blocked?
Offline  
Old 06-21-2010, 11:45 AM   #173 (permalink)
New Member
 
Join Date: Jun 2010
Model: 8900
PIN: N/A
Carrier: Wind
Posts: 2
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi Aviator168,
i've already opened the 5060 and 3478 UDP ports, but nothing happens :(
my router is a Telecom Alice W-gate, the old black version, on which i've loaded a compatible broadcom firmware for more versatility...
Offline  
Old 06-21-2010, 05:21 PM   #174 (permalink)
New Member
 
Join Date: Mar 2010
Model: bold
PIN: N/A
Carrier: STC saudi arabia
Posts: 1
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ixlwqwmqtx View Post
I have installed v0.52 on my BB 9000. When I make a call I am not able to hear any ringing through the handset. I am not able to get the audio to work on either of my BB 9000 or BB 9700.

EDIT: It is working on the BB9000 now (after a reboot). But the audio is very loud and, as you said before, it is not possible to adjust the audio. It is too loud to be very usable for anything but testing.
I installed v0.52 on by BB9700 but the audio still is not working on that device.
kindly post your settings, i have BB9000 but I cant get the good setting. Im from KSA, provider STC.
Offline  
Old 06-22-2010, 03:18 AM   #175 (permalink)
New Member
 
Join Date: May 2010
Model: 9700
PIN: N/A
Carrier: Mobily
Posts: 3
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

@ Aviator168 and development team great job.......

Some issues for consideration of development team and understand its usual as still product in beta phase :

1. It crashes often
2. Conversation sound is low
2. Some times don't hear the ring for incoming call untill reboot the device
3. Some times don't hear the ring for outgoing call
4. Some times no sound from the other end.

Using the latest beta .56 with BB 9700.

Thanks again for your efforts and you are pioneer of BB SIP.
Offline  
Old 06-22-2010, 04:23 AM   #176 (permalink)
Talking BlackBerry Encyclopedia
 
lmcjipo's Avatar
 
Join Date: Nov 2009
Location: Montreal, Quebec (Canada)
Model: Q10
OS: 10.3.1
PIN: N/A
Carrier: Bell Wireless
Posts: 230
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by cuted View Post
@ Aviator168 and development team great job.......

Some issues for consideration of development team and understand its usual as still product in beta phase :

1. It crashes often
2. Conversation sound is low
3. Some times don't hear the ring for incoming call untill reboot the device
4. Some times don't hear the ring for outgoing call
5. Some times no sound from the other end.

Using the latest beta .56 with BB 9700.

Thanks again for your efforts and you are pioneer of BB SIP.
For me, as additional feedback, I'm also using a Bold 9700 with Beta 0.56.

I don't experience #1 & #2.

In terms of #3, I've only been testing mine for outgoing calls so I can't comment on this.

With #4, I can hear the outgoing ring almost all the time (>95% of the time).

With #5, I will add that whether I use it on Wi-Fi or with my carrier over the 3G network, the incoming voice quality is decent but the outgoing voice quality is problematic (others complain that my voice cuts in and out during the call whereas I can hear them without any issues most of the time).
__________________
Bell Wireless (data plan): Factory Unlocked Blackberry Passport (Black)

My Tech Blog
Offline  
Old 06-22-2010, 06:32 AM   #177 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Issues.

1) If wifi goes out of range while on call, it will crack. This would be an easy fix. We will take the action of disconnecting the call.

2) Relating to OS 5.xx.xx.xxx. Specifically to the BB 9700. It takes at least 4 seconds to activate the speaker (sound) on the device. That means, the ring tone won't start at least 4 seconds after the message "Incoming call" shows up, and some times takes long as you might be on the silence period of the ring cycle.

3) Sometime no sound for outgoing calls. This might due to BlackVoib did not receive the "180" ringing SIP message as UDP does not guarantee data delivery.
Offline  
Old 06-22-2010, 09:04 AM   #178 (permalink)
Talking BlackBerry Encyclopedia
 
Join Date: Dec 2004
Location: Atlanta, GA
Model: 8700c
Carrier: Cingular
Posts: 203
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I still haven't made BlackVoib work from my local network. I have an Edgemarc 4500 router from Edgewater Networks. The Edgemarc has a VoIP proxy built in. My phones register with the Edgemarc, and the Edgemarc registers with my Asterisk server on their behalf. The Asterisk server is in a remote data center. The proxy server in the Edgemarc fixes the problems with using SIP on a NAT'd network. So, I should not need a stun server, I believe. Can I just leave stunserver blank?

I have specified both the internal and the external address of the Edgemarc as the outbound proxy server, but any time I check Use WiFi I get
"ip address of registrar cannot be resolved" and ip address of "outbound proxy cannot be resolved" . The domain name of the asterisk server resolvable. The internal address of my Edgemarc isn't public, but it has a resolvable external name.

Another interesting thing - I did a tcpdump on my router, and when it is in WiFi mode I'm seeing this...


REGISTER sip:sip.org SIP/2.0
Via: SIP/2.0/UDP 192.168.100.172:9010;branch=1234567890;rport
Max-Forwards: 70
Contact: <sip:aviator168@192.168.0.1:5060;rinstance=1234567 890>;expires=0
To: "12345"<sip:aviator168@sip.org>
From: "12345"<sip:aviator168@sip.org>;tag=a25e2f7e
Call-ID: 1234567890
CSeq: 1 REGISTER
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO
Content-Length: 0

It's sending these registers to my asterisk server. Those registeration attempts seem to always fail.


I know my case may be a little strange (Edgmarc router), but just thought I would pass this along.
Offline  
Old 06-22-2010, 09:31 AM   #179 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dozment View Post
I still haven't made BlackVoib work from my local network. I have an Edgemarc 4500 router from Edgewater Networks. The Edgemarc has a VoIP proxy built in. My phones register with the Edgemarc, and the Edgemarc registers with my Asterisk server on their behalf. The Asterisk server is in a remote data center. The proxy server in the Edgemarc fixes the problems with using SIP on a NAT'd network. So, I should not need a stun server, I believe. Can I just leave stunserver blank?

I have specified both the internal and the external address of the Edgemarc as the outbound proxy server, but any time I check Use WiFi I get
"ip address of registrar cannot be resolved" and ip address of "outbound proxy cannot be resolved" . The domain name of the asterisk server resolvable. The internal address of my Edgemarc isn't public, but it has a resolvable external name.

Another interesting thing - I did a tcpdump on my router, and when it is in WiFi mode I'm seeing this...


REGISTER sip:sip.org SIP/2.0
Via: SIP/2.0/UDP 192.168.100.172:9010;branch=1234567890;rport
Max-Forwards: 70
Contact: <sip:aviator168@192.168.0.1:5060;rinstance=1234567 890>;expires=0
To: "12345"<sip:aviator168@sip.org>
From: "12345"<sip:aviator168@sip.org>;tag=a25e2f7e
Call-ID: 1234567890
CSeq: 1 REGISTER
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, NOTIFY, MESSAGE, SUBSCRIBE, INFO
Content-Length: 0

It's sending these registers to my asterisk server. Those registeration attempts seem to always fail.


I know my case may be a little strange (Edgmarc router), but just thought I would pass this along.
What is being send back from the Edgmarc router when the registration fails? BlackVoib expected a SIP error code.
Offline  
Old 06-22-2010, 09:33 AM   #180 (permalink)
Thumbs Must Hurt
 
Join Date: Feb 2010
Model: 9000
PIN: N/A
Carrier: AT&T
Posts: 119
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just a reminder. All support issues should be posted on the discussion forum on our site.

BlackVoib
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Universal BGA Reballing Stencils Kit 3pcs For MTK Samsung HTC Huawei Android 3pc
$4.56
Universal BGA Reballing Stencils Kit 3pcs For MTK Samsung HTC Huawei Android 3pc pictureGenuine Samsung JC96-06292A Transfer Belt Unit
$103.68
Genuine Samsung JC96-06292A Transfer Belt Unit pictureOverwatch ~ 5 Phone Case for iPhone/Samsung/HTC/LG/Google
$20.0
Overwatch ~ 5 Phone Case for iPhone/Samsung/HTC/LG/Google pictureOverwatch ~ 5 Phone Case for iPhone/Samsung/HTC/LG/Google
$20.0
Overwatch ~ 5 Phone Case for iPhone/Samsung/HTC/LG/Google pictureOverwatch ~ 5 Phone Case for iPhone/Samsung/HTC/LG/Google
$20.0
Overwatch ~ 5 Phone Case for iPhone/Samsung/HTC/LG/Google picture






Copyright 2004-2016 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.