BlackBerry Forums Support Community               

Closed Thread
 
LinkBack Thread Tools
Old 08-25-2007, 08:16 PM   #1 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default Viigo and Permissions

Please Login to Remove!

I tried posting this in the General Discussion, but I didn't get a reply, so I'm going to try posting this here...

I recently installed Viigo on my Curve 8300R. Everytime Viigo is pulling RSS feeds or searching for channels, I get a prompt asking if I want to allow it network access. Saying No to this prompt halts any action Viigo is doing. Just to check RSS feeds, this prompt appears about 5-10 times.

Is there a way to suppress this message or have an auto "Yes"? I have tried going into the Application Permissions in the security settings and changing it, but even will a full "Allow" across all the settings I still get that prompt.

Viigo is a great RSS reader and I would like to keep it. I just want to know how to get rid of this annoying prompt.

Thanks!
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173
Offline  
Old 08-25-2007, 11:55 PM   #2 (permalink)
BlackBerry Extraordinaire
 
rivviepop's Avatar
 
Join Date: Dec 2006
Location: san francisco
Model: 8320
PIN: n/a
Carrier: t-mobile
Posts: 2,166
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hmmm, this doesn't happen on the 8100 so it sounds fishy. Have you tried uninstalling ViigoSE, rebooting, then reinstalling it from their OTA link? Make sure you've made a user/password first to save all your channels on their server (backup/restore kinda).

Maybe it's got a screwed up config file or something that just needs a scrub. $0.02, just a guess.
__________________
[ Linux & BlackBerry ] http://www.blackberryforums.com/linux-users-corner/
Offline  
Old 08-26-2007, 12:14 AM   #3 (permalink)
BBF Moderator
 
Stinsonddog's Avatar
 
Join Date: Mar 2005
Location: Northern California
Model: 9700
PIN: Agaboobie
Carrier: AT&T
Posts: 5,518
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

You need the reset your firewall not the persmissions. In the more advanced OS there is an menu item under Advanced Options. Let us know if that works.
__________________
Shortcuts Rule!! Download Link:[Stinsonddog's Blackberry Tips ] GET TORCHED
@ Stinsonddog
Offline  
Old 08-26-2007, 12:27 AM   #4 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

When that popup window comes up, you don't get the option to "don't ask me this again?"
Offline  
Old 08-26-2007, 12:41 AM   #5 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by rivviepop View Post
Hmmm, this doesn't happen on the 8100 so it sounds fishy. Have you tried uninstalling ViigoSE, rebooting, then reinstalling it from their OTA link? Make sure you've made a user/password first to save all your channels on their server (backup/restore kinda).

Maybe it's got a screwed up config file or something that just needs a scrub. $0.02, just a guess.
I tried that. Didn't work. The installation went fine and I don't suspect that it is an issue with any kind of config file.

Quote:
Originally Posted by Stinsonddog View Post
You need the reset your firewall not the persmissions. In the more advanced OS there is an menu item under Advanced Options. Let us know if that works.
I tried this as well without luck. My firewall was never on anyways.

Quote:
Originally Posted by John Clark View Post
When that popup window comes up, you don't get the option to "don't ask me this again?"
No. It's just a yes/no prompt.
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173
Offline  
Old 08-26-2007, 12:46 AM   #6 (permalink)
BBF Moderator
 
Stinsonddog's Avatar
 
Join Date: Mar 2005
Location: Northern California
Model: 9700
PIN: Agaboobie
Carrier: AT&T
Posts: 5,518
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok do this please - I'll be more clear - or for a certain mod friend I tease - I'll type slower- Go into Advanced Options>Applications>Scroll to Viigo and go Open up permissions. Then when its open hit the menu key and reset firewall prompts. Please do this then report back.
__________________
Shortcuts Rule!! Download Link:[Stinsonddog's Blackberry Tips ] GET TORCHED
@ Stinsonddog
Offline  
Old 08-26-2007, 12:49 AM   #7 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Stinsonddog View Post
Ok do this please - I'll be more clear - or for a certain mod friend I tease - I'll type slower- Go into Advanced Options>Applications>Scroll to Viigo and go Open up permissions. Then when its open hit the menu key and reset firewall prompts. Please do this then report back.
I have followed your instructions and I have reset firewall prompts. This did not change anything
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173
Offline  
Old 08-26-2007, 12:51 AM   #8 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

Or, when you are in there, set all the permissions to "allow." Resetting them will work and should give you the prompt when the app opens up. Setting them to "allow" should just allow access.

I have to ask....You're not on a BES are you? If not has your BB ever been on a BES?
Offline  
Old 08-26-2007, 12:55 AM   #9 (permalink)
BBF Moderator
 
Stinsonddog's Avatar
 
Join Date: Mar 2005
Location: Northern California
Model: 9700
PIN: Agaboobie
Carrier: AT&T
Posts: 5,518
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by KamileonX View Post
I have followed your instructions and I have reset firewall prompts. This did not change anything
One more try - did you read the first prompt that came up? Did it give you the choice to allow all connections and not be asked again?
__________________
Shortcuts Rule!! Download Link:[Stinsonddog's Blackberry Tips ] GET TORCHED
@ Stinsonddog
Offline  
Old 08-26-2007, 01:29 AM   #10 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by John Clark View Post
Or, when you are in there, set all the permissions to "allow." Resetting them will work and should give you the prompt when the app opens up. Setting them to "allow" should just allow access.

I have to ask....You're not on a BES are you? If not has your BB ever been on a BES?

I have changed them all to allow and I still get the prompt.

No my blackberry is not and never has been on BES. I just use the BIS for email.
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173
Offline  
Old 08-26-2007, 01:30 AM   #11 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Stinsonddog View Post
One more try - did you read the first prompt that came up? Did it give you the choice to allow all connections and not be asked again?
The first prompt was no different than all the rest. There was no option.


This is a dilly of a Pickle huh? (Think Ned Flanders)
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173
Offline  
Old 08-26-2007, 10:16 AM   #12 (permalink)
BBF Moderator
 
Stinsonddog's Avatar
 
Join Date: Mar 2005
Location: Northern California
Model: 9700
PIN: Agaboobie
Carrier: AT&T
Posts: 5,518
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by KamileonX View Post
The first prompt was no different than all the rest. There was no option.


This is a dilly of a Pickle huh? (Think Ned Flanders)
Ok then start from scratch. Delete the app, but first check what modules it has and delete all the modules. Then reset the firewall - first method and try again. If that doesn't help, I am not sure what will cause this aint normal.
__________________
Shortcuts Rule!! Download Link:[Stinsonddog's Blackberry Tips ] GET TORCHED
@ Stinsonddog
Offline  
Old 08-26-2007, 03:31 PM   #13 (permalink)
BBF Moderator
 
John Clark's Avatar
 
Join Date: Jun 2005
Model: Z30
OS: 10.2.1.x
PIN: s & needles
Carrier: AT&T
Posts: 34,686
Post Thanks: 4
Thanked 100 Times in 72 Posts
Default

It might be time to contact Viigo.
Offline  
Old 09-05-2007, 12:25 AM   #14 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have contact Viigo, and I have talked to them over the phone and via email. They don't have a solution yet.

Does ANYONE else have this problem? Does ANYONE using a CURVE have this problem?
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173

Last edited by KamileonX : 09-05-2007 at 12:26 AM.
Offline  
Old 09-05-2007, 04:01 PM   #15 (permalink)
Thumbs Must Hurt
 
KamileonX's Avatar
 
Join Date: Mar 2007
Location: Toronto, Ontario, Canada
Model: 8300R
PIN: Just Ask =)
Carrier: Rogers
Posts: 88
Post Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a round-about (Emphasis on ROUND-ABOUT) way to fix the problem. I really like Viigo, but that prompt was annoying the hell out of me.

Eventually I backed up my Blackberry, and totally wiped it with JL_Cmder. Then I installed the latest OS for the Curve (4.2.2.265), and BEFORE applying my Restore, I installed Viigo on the newly installed OS. Viigo worked flawlessly. So then I performed my restore, and Viigo still works.

I guess there was some kind of random setting that prevented Viigo from accessing the network without a prompt? But anyways, my Blackberry is jsut as good as it was before, but now with Viigo working properly.
__________________
Lawrence Wong
Blackberry 8300R Curve
OS Pkg: 4.2.2.314 - App Pkg 4.2.2.173
Offline  
Closed Thread


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On





Copyright 2004-2014 BlackBerryForums.com.
The names RIM and BlackBerry are registered Trademarks of BlackBerry Inc.