View Full Version : My Number: Unknown

11-09-2007, 12:05 AM
My phone setting in General Option is "Yes" for Show "My Number", but it does not show on the screen now while in Phone mode. My Number used to be displayed but suddenly changed to "Unknow" now. Is there anybody who had the same experience, pls. advise how did you correct it.

Thank you.

John Clark
11-09-2007, 12:09 AM
Options >Advanced Options >Sim Card. Higlight the phone number field and click the wheel and select "Edit SIM Phone Number."

11-09-2007, 12:21 AM
Thanks John,

Done it but can't see phone number field after clicking "Sim Card", I saw a long series of numbers, click on its highlight, still My Number not shown.

11-09-2007, 05:42 PM
I've also had this problem forever--- John Clark's solution works. Just click "Edit Phone Number" on the trackwheel and it will create a new line for you to enter the phone number- after you enter it, problem solved.

11-09-2007, 07:34 PM
Thank you John and Allan,

I did what you were suggesting. The phone number was not appearing on Sim Card option, so I can't do "Edit Phone Number". However, as I have read in this forum, I pulled out the the battery and reinstall again, then everything works well.