View Full Version : What changed in the last 24 hours

02-14-2008, 06:52 PM
Please help... Today one of my applications stopped working today.

This a video viewer called celvu.com that we developed a couple of years ago. The application should connect to our server on port 1500, but no connection is being established.

It worked fine last night and still works on a blackberry simulator running on a PC. The same J2ME is still working on other cellphones. I have also checked that I can connect to the server from the blackberry using Idokorro ssh and even tested mapping ssh to port 1500 to confirm there is no filter blocking the path.

I've now spent over six hours diagnosing the problem without success, having eliminated everything. Does anyone know what might have changed in the network in the last 24 hours. My best guess right now is that something may have been pushed onto the blackberry and corrupted the device. Reinstalling the application has not fixed the problem.

02-14-2008, 07:11 PM
I had a remote camera working without any issues for two years on a BB. The remote camera would send a view shot to the BB and to get an update I would hit "R" and it would refresh. The camera was running full frame to a 6meg DSL line so from a PC connecting to it would be full motion. Well all of a sudden it stopped working. I thought it was the camera so I reloaded the OS on it . No Luck.
Then I played with software on the BB, No luck. SO I upgraded the OS on the BB. Again no Luck.

I set up an Ethernet analyzer on the camera port and found it was indeed sending a few frame’s . After a little thought I determined it was the Cell network that was blocking the continuous frame’s . I reset the camera to only send single snap shots on connect or refresh request.
It is now working. I make the assumption that the carrier was blocking the continuous traffic and dropping the data stream. Apparently they now sell the service and figured out a method to block those who do not subscribe.
If you can set it to single frame shots it may work . Not sure if you carrier is doing this but worth a try.

Good Luck

02-14-2008, 07:12 PM
By the way, Welcome to the forums.!!

02-14-2008, 08:38 PM
Thanks for the welcome.

The application has worked fine for two years until today.

In my latest test, I used the BB as a modem tethered to the PC and then ran the application on the BB simulator. This way the protocols over the Telus EV-DO network would be the same as normal. The application worked perfectly.

In conclusion, something has changed in the software on the target BB. I know I did not change anything and have to conclude RIM must have pushed out an update!

BTW: Last night I notice the display go blank a couple of times as though the display or battery connection was bad. Since then the display has worked fine - I'm convinced there was an update of some sort.

At this point I think I'll leave it until next week and see if it cures itself. It is a pity as we had a potential sale and my customer seems to experiencing similar problems.

02-14-2008, 10:26 PM
too bad . the carrier more than likely did make a change.
Good Luck

02-15-2008, 04:06 PM
Well I never... my application suddenly started working this afternoon. Must be related to the recent upgrades and I only lost a day to this incident.

The only remaining concern now is how defenseless we are to the carrier or RIM breaking the application. What if I had more customers depending on our application.