View Full Version : O2 UK - Browser Configuration

04-27-2008, 03:36 PM
On my new Pearl from O2 if I select the browser then options then Browser Configuration the browser is set to 'O2 Active'. Is this correct as I've read somewhere on the forums that using O2 active could be billable rather than included in your data plan. What's the difference between O2 Active and Internet Browser?

Interestingly my girl friends BB also shows up as 'O2 active making me think this must be the setting it's shipped with.

04-27-2008, 06:46 PM
Wirelessly posted

I am on o2 and my default browser is internet browser. This is best for downloading etc.

From February 2008 wap (o2 active)charges are included in the 200mb allowance so you would only be charged extra if you went over this 200mb allowance.

If you use the Opera mini browser with o2 mobileweb settings you will be charged extra as mobileweb is not included in the 200mb allowance.

Internet browser uses blackberry.net gateway & o2 active uses o2wap gateway.

04-28-2008, 02:44 AM
Thanks Foxglove.

I changed my default browser to Internet Browser in General Configuration but no matter what I do I cannot get the Browser Configuration screen to stay on Internet Browser. Even though I save changes every time I open the screen it shows O2 Active.

I thought maybe it's just showing the settings for O2 active and it's actually using internet browser but I tested it by setting different home pages for each settings and it's using the settings for O2 active. Any idea what's going on?

04-28-2008, 02:55 AM
More info.... If I close the browser down then open at the start page then make the change to Internet Browser I can get it to stick but as soon as I start browsing any pages it changes back to O2 Active.

Can anyone on O2 replicate this?

04-28-2008, 03:14 AM
I tend not to set the default browser from within the browser, but via the options menu
options > advanced options > browser > default browser configuration
my choices are: hotspot browser (wifi), o2active & internet browser.

to be honest, I never use o2active as I find the wap gateway to be painfully slower than the blackberry.net gateway.

04-28-2008, 04:17 AM
Wirelessly posted

I don't use the wap gateway either.

Try changing the default browser from the options menu as stated by Tornadodivine.

Your default really should stay on the one you choose.

04-28-2008, 04:22 AM
Wirelessly posted

Try this. From your browser hit menu key, select options then browser configuration. Set default to internet browser then scroll down & set emulation mode to BlackBerry. Exit to save.

04-28-2008, 06:10 AM
Wirelessly posted

Try this. From your browser hit menu key, select options then browser configuration. Set default to internet browser then scroll down & set emulation mode to BlackBerry. Exit to save.
I've done that, and changed it via the options but it makes no difference. Whilst the default stays on Internet Browser the browser config screen always goes back to O2 Active. If I select the home page via the menu key it always goes to the home page specified in the O2 active settings rather than the internet browser settings. I'm stumped.

04-28-2008, 06:37 AM
Some bookmarked pages are set to use certain browser types - I have one called o2 Active which, even though my default browser config is hotspot, will always use the o2active browser. And you can't get rid of this bookmark either. The Blackberry homepage seems to be set to use internet browser.

When I open the browser, first thing I see is a list of bookmarks and then history. At the top of the screen (where the signal strength is etc.) it tells you what browser config you are using. This should match the default browser in options > advanced options > browser

04-28-2008, 06:41 AM
my browser homepages are as follows:
hotspot: mobile.blackberry.com
o2active: wap.o2.co.uk
internet: www.blackberry.com/mobile/o2uk

I've not changed these, so this is what was setup when I bought the phone

04-28-2008, 07:07 AM
Yeh I get it know. Maybe I was being dumb or maybe it's just not very intuitive but I hadn't realised bookmarks were associated with a browser type. I've deleted all my bookmarks under O2 active and set them up against internet browser and now all is ok. :)

04-28-2008, 07:34 AM
Wirelessly posted


04-28-2008, 10:22 AM
awesome :)

10-22-2008, 06:15 AM
In settings/advanced settings you can set the start page to be either bookmarks, last visited page or the stored home page