PDA

View Full Version : USB Port problem


papaguya
05-27-2008, 11:04 AM
I was about to post about my broken usb port on my 8830 and noticed it is a pretty common problem. I took the phone apart to realize that the port is not actually broken but disconnected from the main board. With 4 small connections I can see how this could easily break with constant connection/disconnection of the power cord. :cry:

I would like to send a comment to posters who reprimand those with broken usb ports claiming they need to be more careful etc. This can happen to anyone not just people who are a little harder on their phones. RIM should construct this piece knowing that it will receive the most wear and tear on the device. 10 months in of normal use and it breaks?

I am the BES admin for my company and have used every BB known. It seems some of the new gen bbs (81xx,88xx,83xx) either have a tight fitting USB connection(tough to plug in the cable) and some are loose. Mine was loose from day 1 and purchased within days of it's initial release. I'm guessing they either changed the port due to complaints on the early devices or it's a manufacturing QC issue.

On the lighter side, Verizon is replacing my phone under the 1 yr manu warranty so anyone that has this issue, don't wait until it's too late to get it replaced. 8-)

atress
06-13-2008, 07:17 PM
You're very lucky. A gold prong inside of my USB fell out and T-Mobile left me on my own. Mine should be still under warrantee as well, but because its not a 'registered' problem with RIM, its not T-Mobile's problem either.

jkyip2002
01-27-2009, 01:08 AM
My blackberry curve usb port was not working last week. It was under warranty. I called and they sent me a new one. Luckily, the pictures that I took are still in the on board (built-in) memory chip (64MB) I quickly backuped the device memory of this new phone using the Desktop Manager. Just a few hours ago, I tried to charge my phone and found that the sign for charging the phone was not popped up. Then I tried to use the Dwaktop Manager, and Windows XP said the USB was bad and not supported. I went and tried charge it again and somehow I barely make the charging work, but Windows still said it cannot recognize the USN. (It did yesterday.)