PDA

View Full Version : Email stops arriving


techadv
02-05-2009, 02:07 PM
I support several Blackberry devices on various networks and several of the devices exhibit a recurring problem with email. One device in particular is causing us major headaches. This one is a Bold on ATT. I've seen the same problem with older models on other providors as well. In common, they all use Exchange 2007 and the BIS (Internet agent).

At random times throughout the day/night, the Blackberry stops receiving messages. No email will arrive on the handheld until it is re-registered on the network. Rim has an official document addressing this problem however all it states is how to re-register your device on the providor network. This can be done by powering it off and back on, sending yourself an email, going into network options and re-selecting your network, etc.

This "work-around" fixes it every time however the fix is very temporary.
This user never knows if his email has stopped or if he just has not received anything in Outlook lately. We cannot rely on the Blackberries that exhibit this issue. According to RIM, the document describing the work-around is their official fix at this time. Does anyone know of a better resolution to this? We are going to exchange the device for a new one thinking perhaps it has a faulty radio or other component.

knottyrope
02-05-2009, 02:09 PM
You could get a BES server.

techadv
02-05-2009, 02:36 PM
If I was told it was a glitch in their system and a BES would fix it permenantly, I would proceed with BES. At least I would have a definitive answer and understand this is not something my technicians are doing wrong.
RIM will not confirm or deny that they are working on a fix to this. Their standpoint right now is that the problem has been addressed by their work-around. The underlying problem when asked could be either a bug in the system, a user setting, a configuration error or a defective device. Since the problem is random and is fixed by the workaround, I am guessing a bug in the system. ATT found nothing wrong. RIM did not take my support fee because they said ATT has access to the exact same help materials. Evidentially, I'd be wasting my money talking with RIM because ATT already covered all the bases. -One base they didn't touch on yet; I still have no clue as to why this is happening.