View Full Version : "543" Error Icon Home Screen - 8700c

04-19-2009, 08:02 PM
I have a RIM Blackberry 8700C that seems to be having a software issue. Today I attempted to download the Google Maps app through the browser (at&t is the service provider) and after it downloaded the home screen has been stuck an icon with an icon that reads "543". I have attempted to take the battery out and do a hard reset, still showing "543". I then tried to wipe it by entering the password in incorrectly 10 times through desktop manager, and the "543" is still there. This device is my personal email through at&t and not set up on a Blackberry Enterprise Server. I reside in the metro Atlanta, GA area if that makes a difference.

How do I fix this issue?


04-19-2009, 08:21 PM
Did you do the recommended device backup before any downloading or do you have an older backup you can reinstall?

Try these links for some help:

View Document (http://www.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB11212&sliceId=2&docTypeID=DT_SUPPORTISSUE_1_1&dialogID=76265192&stateId=0%200%2076259773)

543 boot error. How do I repair this? - PinStack.com (http://forums.pinstack.com/f19/a-7589/)

You can google error code 543 for other sites that may be of help. Also, do a forum search for the error code 543 there are other discussions on the error code.


04-19-2009, 08:29 PM
You do realize that the 8700 doesn't have GPS, so unless you have a GPS puck, it is not going to be very accurate. GoogleMaps does use cell tower triangulation to locate you within 1700 to 2500 meters, but that isn't very useful for navigation purposes, IMHO,

Also, memory is somewhat limited in the 8700 so as it downloads map data, it could go haywire as well.

04-19-2009, 08:56 PM
Ok, thanks for the advice rugmankc. I just got off the phone with RIM and they suggested that I update the desktop manager software to 4.7 and then download the BlackBerry Handheld Software v4.5.0.152 (Multilanguage) to my PC desktop and then download it to the device. Please let me know if this sounds right. Also, the first time I wiped the device it would not take my password that I created from the device (thats why I did the 10 password thing to wipe it).

04-19-2009, 09:39 PM
What OS is on your PC? And if you are planning to sync to Outlook, what version of that?

Personally, I would try DM 4.6 or 4.7 before tryign to reload the OS. However, reloading the OS seems appropriate for that error code as said above. If you decide to reload, check the sticky at the top of the 8700 section for the latest OS for the 8700 and also for instructions on how to do it. Be patient as it can take an hour or longer to run. Don't disconnect as that will do more harm than good.

04-19-2009, 09:45 PM
I use google maps with no problems on my 8700g.

I would wait for a few more suggestions on your problem, but see no reason to upgarde DM or the device OS and would think about trying the View Document link resolution. Not sure what to do about your password. If you get it fixed I would recommend doing regular backups. I do one a week and keep the last five.

I am no expert but the View Document link fixed a different error code for me. The link is to the Blackberry Internet Site. I haven't had much luck with ISP or Manufacturer telecons. They seem to have predetermined answers and don't think on their feet.

Again, wait for a day to see other suggestions that may be from more expert users.


04-19-2009, 10:01 PM
rugmankc ok thanks for the advice. My service provider runs 4.5 as thier current. I will be linking it to outlook because i use att.net for my email. Anyways, I am not that familiar with desktop mgr and want to know how to browse to find the 4.5 handheld software that I downloaded to my pc. I cant seem to browse and choose it in order to dowload it to my device. can you help? thanks.

04-19-2009, 10:35 PM
Try this:



04-19-2009, 10:50 PM
Ok, thanks for the link.
I was able to get the software downloaded to my pc but now I get to checking the device after i chose which sortware to update and it gives me the last warning that I will need to activate the device wirelessly in order to send / recv messages. It is giving me an error msg saying desktop loader cannot connect to device. You may have to enter password on the device. But i cannot do that because the 543 icon is still up. Now should I see an icon of the bb and a pc connecting on the home screen while it is trying to connect? What should i do now? Thanks

04-20-2009, 01:53 PM
I have downloaded the latest version on Blackberry Desktop Manager 4.7 Software to my PC and then downloaded the latest at&t version of hand held device software 4.5. I am now having an issue downloading the latest version of the software from Desktop Manager to my device. It will allow me to view the 4.7 software and the modules, but I get an error message saying "could not connect device, may need to enter password on the device" . Well I am unable to enter my password on the device because it is still stuck at the "543" icon home screen. It has been like this now for the past 24hours. I visited an at&t corporate retail store this morning hoping they could download the latest software to my blackberry 8700c for me. Not the case. They referred me back to RIM Blackberry. So then what should I do now?

04-20-2009, 03:35 PM
Try wiping the device with JL_Commander:

How do I wipe the BlackBerry using Jl Cmder? - BlackBerryFAQ (http://www.blackberryfaq.com/index.php/How_do_I_wipe_the_BlackBerry_using_Jl_Cmder%3F)

05-31-2009, 06:08 PM
I am receiving the same error! I am asked for a password, but I don't have one. Do you know how to set up a password that its asking for??? Thanks!:smile::smile: