PDA

View Full Version : OS loading problem for my 8700C from 4.1 to 4.2


Zhan
04-23-2009, 12:07 AM
Hi, I just bought a used 8700c from ebay. It is functioning well but the os is still 4.1.377, so I tried to upgraded it to 4.2. I am using DM 4.2 sp1 and the rom is a 4.2 rom from ATT.

When I tried to load the os to the phone, it stopped at the first step connect to the device rom/connecting to boot rom. The phone will not be connected and an error message with appear without defined error cause.

I wiped all the software on the bb and tried to do it all over again. The problem still exists. I tried DM 4.2, 4.3, 4.2 rom, 4.1 rom, 4.5 rom and 4.2 rom from different carrier, but I cannot fix it.

Now, there is a 507 sign on the screen and I cannot load any os.

Can anyone help me with this. Highly appreciate.

brpwn
04-25-2009, 01:25 PM
I'm pretty much a newbie to BB as well, but I had a similar problem. I too purchased my BB via eBay and was shipped a 4.1 OS/Applications. I spoke with RIM tech support and this was the following steps I was walked through to update my BB 8700g.

1. Exit the Desktop Manager
2. Go to BlackBerry - Update your Device Software (http://www.blackberry.com/update) (Must use IE)
3. Plug in your BB via USB to your PC/Mac
4. Click the "Check for Updates" button

From there you should see a list of applications that need updating, and should be able to update through the website, instead of the Desktop Manager. I'm online at the moment, so if you have trouble with that, just hit a quick reply.

dc/dc
04-25-2009, 03:36 PM
Please wipe the device with JL_Cmder, then try loading OS 4.5 to the device again.