PDA

View Full Version : Cannot get data network to work after updating device software


PSP
05-07-2009, 02:03 AM
I have a 8700G. I bought my BB from ebay-unlocked and set it up for use with Bharti Airtel(India) network.

It was working fine except that the desktop software that came with it used to crash at the time of synchronization. I decided to download the updated desktop manager and try synchronizing. This worked well. After doing this the new desktop manager asked whether I want to update the device software to v4.5 from the installed v4.2.

I did this and ever since my EDGE stopped working. I see a lowercase "edge" instead of upper case "EDGE". I cannot receive mails. I noted that my host routing table's entries got deleted. I have called up the operator but they have standard procedures that they have told me that do not get my phone to work. These are

1. Set the network scanning mode to manual. Scan network manually. Switch off. Take out the battery and SIM card. Insert after 10 minutes. Switch on. I have tried this at least 15 times without success.

2. Go to "Host routing table" in advanced options. Press register again. I have tried this at least 5 times without success.

3. Login to the operator account on internet. Resend the service book. I have tried this at least 2-3 times without success.

4. Re-provision the system from the operator end. They have done it as well.

5. Re-register the phone (PIN+IMEI) with the network again.

Nothing can get the phone to start using the data channel again. My GSM works fine otherwise. Can somebody help?

PSP

frra
05-07-2009, 02:18 AM
Have you treid resending the service books. Check Options>Advanced>Service books, maybe you also need to set the TCP/APN setting also under Options>Advanced

PSP
05-07-2009, 05:01 AM
I have resent service books from the server (see point 3 above). Yes TCP and APN are also empty. How do I reset that?