PDA

View Full Version : 7100 Background Noise Problems? Email the RIM CEO here.


xsw
11-13-2005, 02:31 PM
I am on my 3rd 7100g. They all exhibit the same background noise problem. If you have been on the receiving end of the calls, you already know what I mean. If you have heard numerous complaints by the people you're talking to, you already know how frustrating this is. Email the RIM CEO below and complain.

Here's a simple test.

Drive in your car at about 40MPH w/ the windows rolled up, radio off, and fan low. Call your home/office voicemail and don't say much. You will hear a TREMENDOUS amount of background noise! This is what everyone hears when they talk to you. I did something further. On the same stretch of road, I left another voicemail from my cheap (FREE), 2 year old Nokia phone on Cingular. Same driving conditions, and it was so quiet that my voicemail would hang up, because it thinks I am done leaving a message. This occurs w/ or w/o the headset.

If you don't have a car, do the same experiment in a restaurant. Bottom line, this is a mic circuit hardware problem. No firmware fix will work. We need new 7100g's that work.

Email the RIM CEO and tell him how you want your phone replaced with a unit that works. I don't think there is a unit that works yet, but this will prompt them to do something about it. They sure are not monitoring these boards. There are guys here who post 200+ messages who will try to tell you that you're wrong. They are just bored (since they have time to posts that many msgs), and they don't want to bad mouth RIM. Forget them, they are not helping you get your unit replaced. Together, we can make a difference.

Email the CEO: Michael Lazaridis => MLazaridis@<hidden>