View Full Version : 8700 doesn't like talking to Dell Latitude D-series..

01-31-2006, 02:50 PM
A little more information.

Two of my executives recently demanded that they get 8700's, upgrading from 7100g's. We currently run BES3.6. Before anyone say it, I know we should upgrade but it won't happen before BES4.1 come out, hopefully in March. Anyway, for contact synchonization, we have to run the Desktop Manager at the user workstation.

The problem is...neither executive's notebook will recognize the newer devices with Desktop Manager 4.0 installed when trying to synchronize via USB. Actually, it works fine if I can plug the USB cable directly into the notebook. But it doesn't work when the notebook is plugged into a port replicator, the normal conditon for notebooks in the office. I see the OS recognize the device but the Desktop Mangaer never recognizes the device in this configuration.

If I try to run Desktop Manager 3.6 which we previously used, I get a notice that the USB-port's current isn't sufficient to charge the device but at least, the Deskop Manager will procede with normal synchronization while the notebook is plugged into the port replicator.

I tried duplicating this problem on my own identical notebook but I'm not having any problems. I tried swaping the port replicators, USB cables and even moved the hard drive over to another notebook and still go the same results. So, I've pretty much isolated it to software. That said, the the only commonality I can find is that the two notebooks on which this process is failing both have had earlier versions of the Desktop Manager and earlier Crackberrys like the 7290 and 7100.

I've done as clean an install as I could without wiping the drive completely and starting from scratch. I'm looking for new suggestions. During the last install, I cleared the HKLM and HKLU registry entries, the C:\Program Files\Common Files\Research In Motion and C:\Program Files\Research In Motion folders before attemptiing another reinstall. The result is always the same. Neither notebook will recognize and synch with a 8700 via USB.

I've updated the BiOS, Chipset and USB drivers on both notebooks. As said before it works fine outside the port replicator but I need it to work while the notebook is docked. I can't trust the executives to plug-unplug their monitors, keyboards, mice and ethernet cables everyday without damage or other problems. Just docking can be an adventure. I also tried reinstalling the BlackBerry's OS but that had no affect.

Suggestions would appreciated. Thanks,


01-31-2006, 03:46 PM
how bout the notebook system software from the dell site. we had this problem too. And as an aside run the 4.1 desktop manager software.

01-31-2006, 04:26 PM
Sorry, I had a rectal/cranial inversion. We are running Desktop Manager 4.1, not 4.0. I did update the notebook system software on the affected notebooks as well as the BIOS. Any other idea?


01-31-2006, 05:26 PM
I'm using the full docking station with a D600. I did have intermittent problems getting the desktop manager to see the device even though windows would pick it up. I switched from using the usb ports on the back of the DS to the port on the side & it has worked fine since. Both for a 7290 (V4.0) & 8700 (V4.1) & both versions of the desktop manager.

02-01-2006, 09:52 PM
Have you tried turning off power management on the usb hubs in device manager?

Ive had issues with that in the past.

I have an 8700r unit with a d610, and d600 port replicator and have no issues, but i have the power management on the usb root hubs shut off.

02-01-2006, 10:54 PM
If I remember, some people had to uninstall DM then reinstall it when they upgraded to the 8700. Try that.

Mark Rejhon
02-01-2006, 11:07 PM
Try plugging into the bottom USB port, not the top USB port. I find my BlackBerry works much better with my old Dell Inspiron 600M. (It's essentially the same thing as Latitude D600)

Uninstalling and reinstalling worked too sometimes -- make sure to clean Device Manager as well, and reboot, before reinstalling. Yes, temporarily disable power management too -- that sometimes helps too.

02-02-2006, 11:46 AM
Thanks for all the suggestions guys.

Unfortunately, I still have a nonfunctional device through the port replicator at this time. I've found no power management option visible for the USB ports under Windows 2000 Pro unless you guys know of somewhere else I should be looking, that seems to be an XP only feature. I tried uninstalling the device from device manager, followed by uninstalling DM4.1, clearing registry entries and common files, rebooting and reinstalling everything with no luck. I tried this sequence using all the various ports, again, with no luck.

I also tried diabling the Universal Connect option in the BIOS and deleting the "Docked" hardware profile before trying any of this stuff. Still, the device doesn't work when connecting through the port replicator yet works fine when the notebook is undocked and the cable is plugged directly into the notebook. Keep the idea's rolling, the ultimate fix may be rebuilding the OS and starting from scratch but I'd like to avoid that time consuming measure if possible.