PDA

View Full Version : Internet Browser disappeared


jc123
08-26-2006, 01:33 PM
I have an 8707v on Vodafone in the UK. The Internet Browser icon recently disappeared and I get an "uncaught exception java.lang.illegalstateexception" error on reset.

I've searched the forum and the BlackBerry site and tried the following:
1. Re-registered from the Host Routing Table under Advanced Options
2. Re-sent the service books from BIS (I think it's 1.8)

Registration was successful and I also got a new welcome message, but still no Internet Browser. On reset I still get the error message and no icon appears in the (hidden or otherwise) application list.

Any suggestions as to what to try next?

d_fisher
08-26-2006, 02:49 PM
Backup your handheld, perform a security wipe, and resend the service books.

jc123
08-26-2006, 04:03 PM
Hi Doug
Thanks for that: a partial success. Now I still don't see a browser icon on the apps (or the hidden apps) list, but the java error is gone and I do see a browser on the ALT-ESC list. Problem is, when I select it, I get a new error saying that I don't have any Browser Configuration Service Book Entries.

I've tried re-sending the service book but I think just email stuff is coming through. There's nothing about Browsing on the BIS page that sends the book, and the welcome email just talks about... email. And the browser configuration page in Settings is indeed empty.

It's almost as if Vodafone have decided I can't browse no more. What gives?

jc

jc123
08-26-2006, 04:13 PM
Update: browser is now working again. I did a couple of resets and resends of host routing tables. Finally it's up once more and back on the apps list. It'd be nice if I understood what went wrong... seems like a problem characteristic of an unstable OS somehow...

xkon
08-26-2006, 05:19 PM
Wirelessly posted (BlackBerry8700/4.1.0 Profile/MIDP-2.0 Configuration/CLDC-1.1 VendorID/107)

I am having the exact issue - my troubleshooting has led me to find its the yahoo! Messenger service books, they are now sent with the rogers service books... I deleted the 2 yahoo entries and on reset the browser was back... I tried each of my apps, removing them one by one with no luck...

NADight
08-27-2006, 04:22 AM
Same problem with my 8707v

It started the moment I powered the device up here in France (normally on Voda UK) but maybe a coincidence

Anyway, I have wiped and reloaded several times and each time my two browsers are restored a soon as the service books arrive, but then the exception error message comes back either after a few hours, or whenever I do a hard reset

Xkon, What are the two Yahoo service books called, and if you delete them, how do you make sure they aren't resent?

jax
08-27-2006, 01:31 PM
Yes I have exactly same problem with my 8707v. I'm not sure when it started - although it was probably 10 days ago. Vodafone have been no use whatsoever... I was also roaming when I first noticed it (but I'm not sure whether that has anything to do with it). I deleted all my Browser service books and had them resent - it didn't fix the issue. I thought it may have been something to do with BES - so I wanted to wait until I'd spoken to the BES admin before doing anything else. However it now looks like it might be an OS or Vodafone issue...

Any insight appreciated!

jax
08-27-2006, 03:38 PM
Ah, think I've fixed it on my 8707v (although time will tell!). Took the hint from xkon and started individually deleting the service books. The Yahoo one's didn't make any difference to me - it was one called 'BlackBerry HELP! [BrowserConfig]'. Once I'd deleted that service book and restared the BB (pulled the batery) I got my browsers back.

NADight
08-28-2006, 02:54 AM
Well whatever service book it might be (if it is a service book issue) how do you stop that service book being resent?

jax
08-28-2006, 03:31 PM
The service books aren't automatically sent to you unless you ask for them (push a button in BIS or BES). I imagine if the network / admin updates the service books then they are sent to you.

NADight
08-29-2006, 03:49 PM
I'm not so sure about that.

Thanks to the advice above, I have fixed my problem by deleting the Blackberry HELP service book. It is a 100% fix

However, every few hours or so the service book re-appears, as does the desktop HELP icon. I certainly didn't request it

jax
08-29-2006, 05:08 PM
It's interesting that your service books reappear every few hours - I deleted mine 2 days ago and they haven't come back. Glad that deleting the HELP service book solved the problem - I have no idea what the issue is though (whether it's the service book itself, the system or the network).